Help with Windows Command line FTP....


I am trying to use windows dos prompt FTP to transfer a file up to my ISP. I can do this using a FTP program, but in this case I'll end up writing a script to do this one file automatically. At this point I am having an issue with just manually entering commands and hope that someone can help.

I start ftp from the command prompt in the proper directory. I then log in to my ISP and enter my user ID and password.

Next I use the "put" command to send this small file to my ISP, however all I get following the "put" command is the following line and it hangs at that point

> 200 Port command succesful

When I look at my web account I can see the filename and extension, but the file is empty. I transfer the same file with WS_FTP and it works fine. Since the file name is getting through I would think I don't have an issue with blocked ports in a firewall, etc.

If anyone can help me out, I'd really appreciate it.

I have tried both binary and ascii formats - same result.

Thanks very much,



  • Hi.

    Solution is quite simple. My server is in dutch so I don't know the exact translation of the steps.

    Your windows firewall blocks the ftp program. Goto Windows firewall, change configuration.
    Go to exceptions tab.
    Check 'Display warnings'.
    Choose apply.

    When you launch the dos ftp you will get a warning message. Choose 'unblock' ftp.

    Now everything works fine.


    Mark Stulens
  • Thanks for the help. There were other issues with the "Windows Firewall" but when I simply turned off "Windows Firewall" it worked immediately so your suggestion was absolutely correct. Many thanks for the help!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!