<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <!-- start Mixpanel --><script type="text/javascript">(function(f,b){if(!b.__SV){var a,e,i,g;window.mixpanel=b;b._i=[];b.init=function(a,e,d){function f(b,h){var a=h.split(".");2==a.length&&(b=b[a[0]],h=a[1]);b[h]=function(){b.push([h].concat(Array.prototype.slice.call(arguments,0)))}}var c=b;"undefined"!==typeof d?c=b[d]=[]:d="mixpanel";c.people=c.people||[];c.toString=function(b){var a="mixpanel";"mixpanel"!==d&&(a+="."+d);b||(a+=" (stub)");return a};c.people.toString=function(){return c.toString(1)+".people (stub)"};i="disable track track_pageview track_links track_forms register register_once alias unregister identify name_tag set_config people.set people.set_once people.increment people.append people.track_charge people.clear_charges people.delete_user".split(" ");
for(g=0;g<i.length;g++)f(c,i[g]);b._i.push([a,e,d])};b.__SV=1.2;a=f.createElement("script");a.type="text/javascript";a.async=!0;a.src="//cdn.mxpnl.com/libs/mixpanel-2.2.min.js";e=f.getElementsByTagName("script")[0];e.parentNode.insertBefore(a,e)}})(document,window.mixpanel||[]);

function createUUID() {
    var s = [];
    var hexDigits = "0123456789abcdef";
    for (var i = 0; i < 36; i++) {
        s[i] = hexDigits.substr(Math.floor(Math.random() * 0x10), 1);
    }
    s[14] = "4";  // bits 12-15 of the time_hi_and_version field to 0010
    s[19] = hexDigits.substr((s[19] & 0x3) | 0x8, 1);  // bits 6-7 of the clock_seq_hi_and_reserved to 01
    s[8] = s[13] = s[18] = s[23] = "-";

    var uuid = s.join("");
    return uuid;
}

function createCookie(name,value,days) {
    if (days) {
        var date = new Date();
        date.setTime(date.getTime()+(days*24*60*60*1000));
        var expires = "; expires="+date.toGMTString();
    }
    else var expires = "";
    document.cookie = name+"="+value+expires+"; path=/";
}

function readCookie(name) {
    var nameEQ = name + "=";
    var ca = document.cookie.split(';');
    for(var i=0;i < ca.length;i++) {
        var c = ca[i];
        while (c.charAt(0)==' ') c = c.substring(1,c.length);
        if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
    }
    return null;
}

function eraseCookie(name) {
    createCookie(name,"",-1);
}

mixpanel.init("f4465c6e844f5ae1b85b8701b94a6ccc");

var uuidCookie = readCookie( 'uuid' );
var uuidValue = null;
if ( uuidCookie == null ) {
   uuidValue = createUUID();
   createCookie( 'uuid', uuidValue, 3650 );
   mixpanel.identify( uuidValue );
}
else {
   uuidValue = uuidCookie;
}

//mixpanel.track( "pageview" );

</script><!-- end Mixpanel --><script type="text/javascript" id="nsgpt" data-channel="general" src="//cdn.nsstatic.net/ns/programmersheaven.com.js" async="true"></script><title>How do I set a system-wide _ifdef? - Programmers Heaven</title>
  <link rel="stylesheet" type="text/css" href="/themes/Gopi/design/style.css?v=1.6" media="all" />
  <link rel="stylesheet" type="text/css" href="/resources/design/vanillicon.css?v=2.3.1" media="all" />
  <link rel="stylesheet" type="text/css" href="/plugins/editor/design/editor.css?v=1.7.7" media="all" />
  <link rel="stylesheet" type="text/css" href="/themes/Gopi/design/custom.css?v=1.6" media="all" />
  <link rel="stylesheet" type="text/css" href="/themes/Gopi/design/custom_dark.css?v=1.6" media="all" />
  <link rel="stylesheet" type="text/css" href="/applications/dashboard/design/spoilers.css?v=2.3.1" media="all" />
  <link rel="canonical" href="http://programmersheaven.com/discussion/438576/how-do-i-set-a-system-wide-ifdef" />
  <meta property="og:type" content="article" />
  <meta property="fb:app_id" content="117243131649354" />
  <meta property="og:site_name" content="Programmers Heaven" />
  <meta property="og:title" itemprop="name" content="How do I set a system-wide _ifdef?" />
  <meta property="og:url" content="http://programmersheaven.com/discussion/438576/how-do-i-set-a-system-wide-ifdef" />
  <meta name="description" property="og:description" itemprop="description" content="How do I set a system-wide _ifdef? This is using Microsoft Visual Stuedio version 2019 with C#." />
  <script type="text/javascript">gdn=window.gdn||{};gdn.meta={
    "ConfirmDeleteCommentHeading": "Delete Comment",
    "ConfirmDeleteCommentText": "Are you sure you want to delete this comment?",
    "Spoiler": "Spoiler",
    "show": "show",
    "hide": "hide",
    "emoji": {
        "assetPath": "\/resources\/emoji",
        "format": "<img class=\"emoji\" src=\"%1$s\" title=\"%2$s\" alt=\"%2$s\" height=\"20\" \/>",
        "emoji": {
            "smile": "smile.png",
            "smiley": "smiley.png",
            "wink": "wink.png",
            "blush": "blush.png",
            "neutral": "neutral.png",
            "relaxed": "relaxed.png",
            "grin": "grin.png",
            "joy": "joy.png",
            "sweat_smile": "sweat_smile.png",
            "lol": "lol.png",
            "innocent": "innocent.png",
            "naughty": "naughty.png",
            "yum": "yum.png",
            "relieved": "relieved.png",
            "love": "love.png",
            "sunglasses": "sunglasses.png",
            "smirk": "smirk.png",
            "expressionless": "expressionless.png",
            "unamused": "unamused.png",
            "sweat": "sweat.png",
            "pensive": "pensive.png",
            "confused": "confused.png",
            "confounded": "confounded.png",
            "kissing": "kissing.png",
            "kissing_heart": "kissing_heart.png",
            "kissing_smiling_eyes": "kissing_smiling_eyes.png",
            "kissing_closed_eyes": "kissing_closed_eyes.png",
            "tongue": "tongue.png",
            "disappointed": "disappointed.png",
            "worried": "worried.png",
            "angry": "angry.png",
            "rage": "rage.png",
            "cry": "cry.png",
            "persevere": "persevere.png",
            "triumph": "triumph.png",
            "frowning": "frowning.png",
            "anguished": "anguished.png",
            "fearful": "fearful.png",
            "weary": "weary.png",
            "sleepy": "sleepy.png",
            "tired_face": "tired_face.png",
            "grimace": "grimace.png",
            "bawling": "bawling.png",
            "open_mouth": "open_mouth.png",
            "hushed": "hushed.png",
            "cold_sweat": "cold_sweat.png",
            "scream": "scream.png",
            "astonished": "astonished.png",
            "flushed": "flushed.png",
            "sleeping": "sleeping.png",
            "dizzy": "dizzy.png",
            "no_mouth": "no_mouth.png",
            "mask": "mask.png",
            "star": "star.png",
            "cookie": "cookie.png",
            "warning": "warning.png",
            "mrgreen": "mrgreen.png",
            "heart": "heart.png",
            "heartbreak": "heartbreak.png",
            "kiss": "kiss.png",
            "+1": "+1.png",
            "-1": "-1.png",
            "grey_question": "grey_question.png",
            "trollface": "trollface.png",
            "error": "grey_question.png"
        }
    },
    "DiscussionID": "438576",
    "Category": "C# & VB.NET School Support",
    "AnalyticsTask": "tick",
    "TagHint": "Start to type...",
    "editorVersion": "1.7.7",
    "editorPluginAssets": "\/plugins\/editor",
    "wysiwygHelpText": "You are using <a href=\"https:\/\/en.wikipedia.org\/wiki\/WYSIWYG\" target=\"_new\">WYSIWYG<\/a> in your post.",
    "bbcodeHelpText": "You can use <a href=\"http:\/\/en.wikipedia.org\/wiki\/BBCode\" target=\"_new\">BBCode<\/a> in your post.",
    "htmlHelpText": "You can use <a href=\"http:\/\/htmlguide.drgrog.com\/cheatsheet.php\" target=\"_new\">Simple HTML<\/a> in your post.",
    "markdownHelpText": "You can use <a href=\"http:\/\/en.wikipedia.org\/wiki\/Markdown\" target=\"_new\">Markdown<\/a> in your post.",
    "textHelpText": "You are using plain text in your post.",
    "editorWysiwygCSS": "\/plugins\/editor\/design\/wysiwyg.css",
    "canUpload": false,
    "maxUploadSize": 2097152,
    "editorFileInputName": "editorupload",
    "allowedFileExtensions": "[\"txt\",\"jpg\",\"jpeg\",\"gif\",\"png\",\"bmp\",\"tiff\",\"ico\",\"zip\",\"gz\",\"tar.gz\",\"tgz\",\"psd\",\"ai\",\"fla\",\"pdf\",\"doc\",\"xls\",\"ppt\",\"docx\",\"xlsx\",\"log\",\"rar\",\"7z\"]",
    "maxFileUploads": "20",
    "LastCommentID": 0,
    "TransportError": "A fatal error occurred while processing the request.<br \/>The server returned the following response: %s",
    "TransientKey": null,
    "WebRoot": "http:\/\/programmersheaven.com\/",
    "UrlFormat": "\/{Path}",
    "Path": "discussion\/438576\/how-do-i-set-a-system-wide-ifdef",
    "Args": "",
    "ResolvedPath": "vanilla\/discussion\/index",
    "ResolvedArgs": {
        "DiscussionID": "438576",
        "DiscussionStub": "how-do-i-set-a-system-wide-ifdef",
        "Page": ""
    },
    "SignedIn": 0,
    "ConfirmHeading": "Confirm",
    "ConfirmText": "Are you sure you want to do that?",
    "Okay": "Okay",
    "Cancel": "Cancel",
    "Search": "Search"
};</script>
  <script src="//ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js?v=2.3.1" type="text/javascript"></script>
  <script src="/js/library/jquery.form.js?v=2.3.1" type="text/javascript"></script>
  <script src="/js/library/jquery.popup.js?v=2.3.1" type="text/javascript"></script>
  <script src="/js/library/jquery.gardenhandleajaxform.js?v=2.3.1" type="text/javascript"></script>
  <script src="/js/library/jquery.atwho.js?v=2.3.1" type="text/javascript"></script>
  <script src="/js/global.js?v=2.3.1" type="text/javascript"></script>
  <script src="/js/library/jquery.autosize.min.js?v=2.3.1" type="text/javascript"></script>
  <script src="/applications/vanilla/js/autosave.js?v=2.3.1" type="text/javascript"></script>
  <script src="/applications/vanilla/js/discussion.js?v=2.3.1" type="text/javascript"></script>
  <script src="/applications/dashboard/js/spoilers.js?v=2.3.1" type="text/javascript"></script>
  <script src="/plugins/editor/js/editor.js?v=1.7.7" type="text/javascript"></script>
  <script src="/plugins/editor/js/jquery.ui.widget.js?v=1.7.7" type="text/javascript"></script>
  <script src="/plugins/editor/js/jquery.iframe-transport.js?v=1.7.7" type="text/javascript"></script>
  <script src="/plugins/editor/js/jquery.fileupload.js?v=1.7.7" type="text/javascript"></script>
  <script src="/themes/Gopi/js/custom.js?v=1.6" type="text/javascript"></script><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5R6MZ2"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5R6MZ2');</script>
<!-- End Google Tag Manager -->
    <link href="https://fonts.googleapis.com/css?family=Open+Sans:100,400,600" rel="stylesheet">
</head>
<body id="vanilla_discussion_index" class="Vanilla Discussion Index  Section-Discussion Section-Category-csharpschool">
    <div class="Head" id="Head">
        <div class="Container">
            <nav class="Row">
                <div class="col-3-nav nav-icon">
                    <ul class="mobile-close">
                        <li><a href="/discussions" class="">Discussions</a></li>
                        <li><a href="/categories" class="">Categories</a></li>
                        
                    </ul>
                    <a class="search" href="#search"><i class="icon icon-search"></i></a>
                </div>
                 <div class="col-3-nav">
                    <a class="logo" href="/">Programmers Heaven</a>
                </div>
                <div class="col-3-nav nav-icon">
                                            <a href='/entry/signin' title='Sign In' class='SignInPopup'><span class='icon icon-signin'><span></a>
                                    </div>
            </nav>
        </div>
    </div>
    <div id="Body" class="Container">

                <div class="Row">
            <div class="col-12 BreadcrumbsWrapper"><span class="Breadcrumbs" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><span class="CrumbLabel CrumbLabel HomeCrumb"><a href="http://programmersheaven.com/" itemprop="url"><span itemprop="title">Home</span></a></span> <span itemprop="child" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><span class="Crumb">›</span> <span class="CrumbLabel Category-dotnet"><a href="//programmersheaven.com/categories/dotnet" itemprop="url"><span itemprop="title">.NET General</span></a></span> <span itemprop="child" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><span class="Crumb">›</span> <span class="CrumbLabel Category-csharpschool Last"><a href="//programmersheaven.com/categories/csharpschool" itemprop="url"><span itemprop="title">C# &amp; VB.NET School Support</span></a></span> </span></span></span></div>
        </div>
                <div class="Row">
            <div class="col-9" id="Content">
                <div class="ContentColumn">
                    <div data-ns="billboard"></div><div class="MessageList Discussion"><!-- Page Title -->
<div id="Item_0" class="PageTitle"><div class="Options"></div><h1>How do I set a system-wide _ifdef?</h1></div>

<div id="Discussion_438576" class="Item ItemDiscussion">
    <div class="Discussion">
        <div class="Item-Header DiscussionHeader">
            <div class="AuthorWrap">
            <span class="Author">
                <a title="xarzu" href="/profile/xarzu" class="PhotoWrap"><img src="http://www.gravatar.com/avatar.php?gravatar_id=2e0c5cba6edebd447399a6ee24ce52ec&amp;amp;size=50&amp;default=http%3A%2F%2Fvanillicon.com%2F2e0c5cba6edebd447399a6ee24ce52ec.png" alt="xarzu" class="ProfilePhoto ProfilePhotoMedium" /></a><a href="/profile/xarzu" class="Username">xarzu</a>            </span>
            <span class="AuthorInfo">
                            </span>
            </div>
            <div class="Meta DiscussionMeta">
            <span class="MItem DateCreated">
                <a href="http://programmersheaven.com/discussion/438576/how-do-i-set-a-system-wide-ifdef" class="Permalink" rel="nofollow"><time title="February 21, 2022  5:08PM" datetime="2022-02-21T17:08:00+00:00">5:08PM</time></a>            </span>
                                 <span class="MItem Category"> in <a href="http://programmersheaven.com/categories/csharpschool">C# &amp; VB.NET School Support</a></span>             </div>
        </div>
                <div class="Item-BodyWrap">
            <div class="Item-Body">
                <div class="Message">
                    <p>How do I set a system-wide _ifdef?</p>

<p>This is using Microsoft Visual Stuedio version 2019 with C#.</p>

<p>If I want to add specialized code to a project shared by multiple software developers that is designed for my selfish tests and evaluation, how do I manage a # definition inside the C# code?</p>

<p>I imagine some soft of solution varable that is deined in either the project file or the solution file that I do not merge with the master branch of the code in the version contorl system.  And then this "# define" is somehow blocked out in the source file.</p>

<p>Has anyone experienced or used such a thing?</p>
                </div>
                <div class="Reactions"></div>            </div>
        </div>
    </div>
</div>
</div><div class="CommentsWrap"><span class="BeforeCommentHeading"></span><div class="DataBox DataBox-Comments">    <ul class="MessageList DataList Comments">
            </ul>
</div><div class="P PagerWrap"></div></div>                <div class="Foot Closed">
                    <div class="Note Closed SignInOrRegister"><a href="/entry/signin?Target=discussion%2F438576%2Fhow-do-i-set-a-system-wide-ifdef%3F" class="Popup">Sign In</a> or <a href="/entry/register?Target=discussion%2F438576%2Fhow-do-i-set-a-system-wide-ifdef%3F">Register</a> to comment.                    </div>
                                    </div>
            
                </div>
            </div>
                        <div class="col-3 PanelColumn" id="Panel">
                <div data-ns="halfpage"></div><div class="Box GuestBox">
    <h4>Howdy, Stranger!</h4>

    <p>It looks like you're new here. If you want to get involved, click one of these buttons!</p>

    <p></p>

    <div class="P"><a href="/entry/signin?Target=discussion%2F438576%2Fhow-do-i-set-a-system-wide-ifdef" class="Button Primary SignInPopup" rel="nofollow">Sign In</a> <a href="/entry/register?Target=discussion%2F438576%2Fhow-do-i-set-a-system-wide-ifdef" class="Button ApplyButton" rel="nofollow">Register</a></div>    </div>
<div class="BoxFilter BoxDiscussionFilter">
    <ul class="FilterMenu">
        <li class="AllCategories"><a href="/categories"><span class="Sprite SpAllCategories"></span> Categories</a></li>         <li class="Discussions"><a href="/discussions" class=""><span class="Sprite SpDiscussions"></span> Recent Discussions</a></li>
                    </ul>
</div>
    <div class="Box BoxCategories">
        <h4>Categories</h4>        <ul class="PanelInfo PanelCategories">
            <li><a href="/categories" class="ItemLink"><span class="Aside"><span class="Count"><span title="140,843 discussions" class="Number">140.8K</span></span></span> All Categories</a></li><li class="ClearFix Heading Category-programming-languages"><span class="Aside"><span class="Count"><span title="103,579 discussions" class="Number">103.6K</span></span></span> Programming Languages</li>
<li class="ClearFix Depth2 Category-pharabee"><a href="http://programmersheaven.com/categories/pharabee" class="ItemLink"><span class="Aside"><span class="Count"><span title="6,391 discussions" class="Number">6.4K</span></span></span> Assembler Developer</a></li>
<li class="ClearFix Depth3 Category-sourceshare"><a href="http://programmersheaven.com/categories/sourceshare" class="ItemLink"><span class="Aside"><span class="Count"><span title="401 discussions" class="Number">401</span></span></span> Assembly Code Share</a></li>
<li class="ClearFix Depth3 Category-asmtips"><a href="http://programmersheaven.com/categories/asmtips" class="ItemLink"><span class="Aside"><span class="Count"><span title="239 discussions" class="Number">239</span></span></span> Getting started in assembly</a></li>
<li class="ClearFix Depth3 Category-x86_asm"><a href="http://programmersheaven.com/categories/x86_asm" class="ItemLink"><span class="Aside"><span class="Count"><span title="4,596 discussions" class="Number">4.6K</span></span></span> x86 Assembly</a></li>
<li class="ClearFix Depth2 Category-basic"><a href="http://programmersheaven.com/categories/basic" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,882 discussions" class="Number">1.9K</span></span></span> Basic</a></li>
<li class="ClearFix Depth3 Category-advbas"><a href="http://programmersheaven.com/categories/advbas" class="ItemLink"><span class="Aside"><span class="Count"><span title="97 discussions" class="Number">97</span></span></span> Qbasic</a></li>
<li class="ClearFix Depth2 Category-candcpp"><a href="http://programmersheaven.com/categories/candcpp" class="ItemLink"><span class="Aside"><span class="Count"><span title="39,949 discussions" class="Number">39.9K</span></span></span> C and C++</a></li>
<li class="ClearFix Depth3 Category-beginnercpp"><a href="http://programmersheaven.com/categories/beginnercpp" class="ItemLink"><span class="Aside"><span class="Count"><span title="5,590 discussions" class="Number">5.6K</span></span></span> Beginner C/C++</a></li>
<li class="ClearFix Depth3 Category-conlunix"><a href="http://programmersheaven.com/categories/conlunix" class="ItemLink"><span class="Aside"><span class="Count"><span title="330 discussions" class="Number">330</span></span></span> C/C++ on Linux/Unix</a></li>
<li class="ClearFix Depth3 Category-win32api"><a href="http://programmersheaven.com/categories/win32api" class="ItemLink"><span class="Aside"><span class="Count"><span title="450 discussions" class="Number">450</span></span></span> C/C++ Windows API</a></li>
<li class="ClearFix Depth3 Category-bcbuilder"><a href="http://programmersheaven.com/categories/bcbuilder" class="ItemLink"><span class="Aside"><span class="Count"><span title="522 discussions" class="Number">522</span></span></span> C++ Builder</a></li>
<li class="ClearFix Depth3 Category-cplusgameprogramming"><a href="http://programmersheaven.com/categories/cplusgameprogramming" class="ItemLink"><span class="Aside"><span class="Count"><span title="253 discussions" class="Number">253</span></span></span> C++ Game Development</a></li>
<li class="ClearFix Depth3 Category-mfc_coding"><a href="http://programmersheaven.com/categories/mfc_coding" class="ItemLink"><span class="Aside"><span class="Count"><span title="3,336 discussions" class="Number">3.3K</span></span></span> C++ MFC</a></li>
<li class="ClearFix Depth3 Category-cppnet"><a href="http://programmersheaven.com/categories/cppnet" class="ItemLink"><span class="Aside"><span class="Count"><span title="103 discussions" class="Number">103</span></span></span> C++.NET</a></li>
<li class="ClearFix Depth3 Category-embedcpp"><a href="http://programmersheaven.com/categories/embedcpp" class="ItemLink"><span class="Aside"><span class="Count"><span title="210 discussions" class="Number">210</span></span></span> Embedded C/C++</a></li>
<li class="ClearFix Depth3 Category-vcpage"><a href="http://programmersheaven.com/categories/vcpage" class="ItemLink"><span class="Aside"><span class="Count"><span title="404 discussions" class="Number">404</span></span></span> Visual C++</a></li>
<li class="ClearFix Depth2 Category-csharp"><a href="http://programmersheaven.com/categories/csharp" class="ItemLink"><span class="Aside"><span class="Count"><span title="2,885 discussions" class="Number">2.9K</span></span></span> C#</a></li>
<li class="ClearFix Depth2 Category-delphikylix"><a href="http://programmersheaven.com/categories/delphikylix" class="ItemLink"><span class="Aside"><span class="Count"><span title="7,943 discussions" class="Number">7.9K</span></span></span> Delphi and Kylix</a></li>
<li class="ClearFix Depth3 Category-advanceddelphi"><a href="http://programmersheaven.com/categories/advanceddelphi" class="ItemLink"><span class="Aside"><span class="Count"><span title="334 discussions" class="Number">334</span></span></span> Advanced Delphi</a></li>
<li class="ClearFix Depth3 Category-delphi"><a href="http://programmersheaven.com/categories/delphi" class="ItemLink"><span class="Aside"><span class="Count"><span title="360 discussions" class="Number">360</span></span></span> Delphi beginners</a></li>
<li class="ClearFix Depth2 Category-haskell"><a href="http://programmersheaven.com/categories/haskell" class="ItemLink"><span class="Aside"><span class="Count"><span title="4 discussions" class="Number">4</span></span></span> Haskell</a></li>
<li class="ClearFix Depth2 Category-java"><a href="http://programmersheaven.com/categories/java" class="ItemLink"><span class="Aside"><span class="Count"><span title="9,676 discussions" class="Number">9.7K</span></span></span> Java</a></li>
<li class="ClearFix Depth3 Category-ejbeans"><a href="http://programmersheaven.com/categories/ejbeans" class="ItemLink"><span class="Aside"><span class="Count"><span title="56 discussions" class="Number">56</span></span></span> Enterprise JavaBeans</a></li>
<li class="ClearFix Depth3 Category-java_beginners"><a href="http://programmersheaven.com/categories/java_beginners" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,312 discussions" class="Number">1.3K</span></span></span> Java Beginners</a></li>
<li class="ClearFix Depth3 Category-jsp"><a href="http://programmersheaven.com/categories/jsp" class="ItemLink"><span class="Aside"><span class="Count"><span title="304 discussions" class="Number">304</span></span></span> Java Server Pages</a></li>
<li class="ClearFix Depth2 Category-pasprog"><a href="http://programmersheaven.com/categories/pasprog" class="ItemLink"><span class="Aside"><span class="Count"><span title="4,135 discussions" class="Number">4.1K</span></span></span> Pascal</a></li>
<li class="ClearFix Depth2 Category-perl"><a href="http://programmersheaven.com/categories/perl" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,270 discussions" class="Number">1.3K</span></span></span> Perl</a></li>
<li class="ClearFix Depth3 Category-perl6"><a href="http://programmersheaven.com/categories/perl6" class="ItemLink"><span class="Aside"><span class="Count"><span title="11 discussions" class="Number">11</span></span></span> Perl 6</a></li>
<li class="ClearFix Depth2 Category-phpstuff"><a href="http://programmersheaven.com/categories/phpstuff" class="ItemLink"><span class="Aside"><span class="Count"><span title="2,007 discussions" class="Number">2K</span></span></span> PHP</a></li>
<li class="ClearFix Depth2 Category-python"><a href="http://programmersheaven.com/categories/python" class="ItemLink"><span class="Aside"><span class="Count"><span title="546 discussions" class="Number">546</span></span></span> Python</a></li>
<li class="ClearFix Depth2 Category-ruby"><a href="http://programmersheaven.com/categories/ruby" class="ItemLink"><span class="Aside"><span class="Count"><span title="37 discussions" class="Number">37</span></span></span> Ruby</a></li>
<li class="ClearFix Depth2 Category-vbnet"><a href="http://programmersheaven.com/categories/vbnet" class="ItemLink"><span class="Aside"><span class="Count"><span title="4,367 discussions" class="Number">4.4K</span></span></span> VB.NET</a></li>
<li class="ClearFix Depth3 Category-theone"><a href="http://programmersheaven.com/categories/theone" class="ItemLink"><span class="Aside"><span class="Count"><span title="258 discussions" class="Number">258</span></span></span> Advanced VB.Net</a></li>
<li class="ClearFix Depth2 Category-vba"><a href="http://programmersheaven.com/categories/vba" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,634 discussions" class="Number">1.6K</span></span></span> VBA</a></li>
<li class="ClearFix Depth2 Category-vbasic"><a href="http://programmersheaven.com/categories/vbasic" class="ItemLink"><span class="Aside"><span class="Count"><span title="20,851 discussions" class="Number">20.9K</span></span></span> Visual Basic</a></li>
<li class="ClearFix Depth3 Category-accessandvb"><a href="http://programmersheaven.com/categories/accessandvb" class="ItemLink"><span class="Aside"><span class="Count"><span title="767 discussions" class="Number">767</span></span></span> Access databases and VB</a></li>
<li class="ClearFix Depth3 Category-vbadvance"><a href="http://programmersheaven.com/categories/vbadvance" class="ItemLink"><span class="Aside"><span class="Count"><span title="831 discussions" class="Number">831</span></span></span> Advance Visual Basic</a></li>
<li class="ClearFix Depth3 Category-vb_beginner"><a href="http://programmersheaven.com/categories/vb_beginner" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,242 discussions" class="Number">1.2K</span></span></span> Beginner VB</a></li>
<li class="ClearFix Heading Category-game"><span class="Aside"><span class="Count"><span title="2,605 discussions" class="Number">2.6K</span></span></span> Game programming</li>
<li class="ClearFix Depth2 Category-console"><a href="http://programmersheaven.com/categories/console" class="ItemLink"><span class="Aside"><span class="Count"><span title="315 discussions" class="Number">315</span></span></span> Console programming</a></li>
<li class="ClearFix Depth2 Category-dxgameprog"><a href="http://programmersheaven.com/categories/dxgameprog" class="ItemLink"><span class="Aside"><span class="Count"><span title="90 discussions" class="Number">90</span></span></span> DirectX Game dev</a></li>
<li class="ClearFix Depth2 Category-minecraft"><a href="http://programmersheaven.com/categories/minecraft" class="ItemLink"><span class="Aside"><span class="Count"><span title="1 discussion" class="Number">1</span></span></span> Minecraft</a></li>
<li class="ClearFix Depth2 Category-newbies"><a href="http://programmersheaven.com/categories/newbies" class="ItemLink"><span class="Aside"><span class="Count"><span title="112 discussions" class="Number">112</span></span></span> Newbie Game Programmers</a></li>
<li class="ClearFix Depth2 Category-ocu"><a href="http://programmersheaven.com/categories/ocu" class="ItemLink"><span class="Aside"><span class="Count"><span title="2 discussions" class="Number">2</span></span></span> Oculus Rift</a></li>
<li class="ClearFix Heading Category-applications"><span class="Aside"><span class="Count"><span title="9,004 discussions" class="Number">9K</span></span></span> Applications</li>
<li class="ClearFix Depth2 Category-graphics"><a href="http://programmersheaven.com/categories/graphics" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,795 discussions" class="Number">1.8K</span></span></span> Computer Graphics</a></li>
<li class="ClearFix Depth3 Category-3d-graphics"><a href="http://programmersheaven.com/categories/3d-graphics" class="ItemLink"><span class="Aside"><span class="Count"><span title="279 discussions" class="Number">279</span></span></span> 3D Graphics</a></li>
<li class="ClearFix Depth3 Category-directx"><a href="http://programmersheaven.com/categories/directx" class="ItemLink"><span class="Aside"><span class="Count"><span title="129 discussions" class="Number">129</span></span></span> DirectX</a></li>
<li class="ClearFix Depth3 Category-opengl"><a href="http://programmersheaven.com/categories/opengl" class="ItemLink"><span class="Aside"><span class="Count"><span title="125 discussions" class="Number">125</span></span></span> OpenGL</a></li>
<li class="ClearFix Depth2 Category-hardware"><a href="http://programmersheaven.com/categories/hardware" class="ItemLink"><span class="Aside"><span class="Count"><span title="740 discussions" class="Number">740</span></span></span> Computer Hardware</a></li>
<li class="ClearFix Depth3 Category-overclocking"><a href="http://programmersheaven.com/categories/overclocking" class="ItemLink"><span class="Aside"><span class="Count"><span title="9 discussions" class="Number">9</span></span></span> Cooling &amp; Overclocking</a></li>
<li class="ClearFix Depth2 Category-database"><a href="http://programmersheaven.com/categories/database" class="ItemLink"><span class="Aside"><span class="Count"><span title="3,449 discussions" class="Number">3.4K</span></span></span> Database &amp; SQL</a></li>
<li class="ClearFix Depth3 Category-access"><a href="http://programmersheaven.com/categories/access" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,081 discussions" class="Number">1.1K</span></span></span> Access</a></li>
<li class="ClearFix Depth3 Category-adoprogramming"><a href="http://programmersheaven.com/categories/adoprogramming" class="ItemLink"><span class="Aside"><span class="Count"><span title="91 discussions" class="Number">91</span></span></span> ADO Programming</a></li>
<li class="ClearFix Depth3 Category-mysql"><a href="http://programmersheaven.com/categories/mysql" class="ItemLink"><span class="Aside"><span class="Count"><span title="288 discussions" class="Number">288</span></span></span> MySQL</a></li>
<li class="ClearFix Depth3 Category-oracle"><a href="http://programmersheaven.com/categories/oracle" class="ItemLink"><span class="Aside"><span class="Count"><span title="358 discussions" class="Number">358</span></span></span> Oracle</a></li>
<li class="ClearFix Depth3 Category-sql-server"><a href="http://programmersheaven.com/categories/sql-server" class="ItemLink"><span class="Aside"><span class="Count"><span title="440 discussions" class="Number">440</span></span></span> SQL-Server</a></li>
<li class="ClearFix Depth2 Category-electronics"><a href="http://programmersheaven.com/categories/electronics" class="ItemLink"><span class="Aside"><span class="Count"><span title="535 discussions" class="Number">535</span></span></span> Electronics development</a></li>
<li class="ClearFix Depth2 Category-ctocplusplustomatlab"><a href="http://programmersheaven.com/categories/ctocplusplustomatlab" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,600 discussions" class="Number">1.6K</span></span></span> Matlab</a></li>
<li class="ClearFix Depth2 Category-sound"><a href="http://programmersheaven.com/categories/sound" class="ItemLink"><span class="Aside"><span class="Count"><span title="628 discussions" class="Number">628</span></span></span> Sound &amp; Music</a></li>
<li class="ClearFix Depth3 Category-directsound"><a href="http://programmersheaven.com/categories/directsound" class="ItemLink"><span class="Aside"><span class="Count"><span title="25 discussions" class="Number">25</span></span></span> DirectSound</a></li>
<li class="ClearFix Depth2 Category-xml"><a href="http://programmersheaven.com/categories/xml" class="ItemLink"><span class="Aside"><span class="Count"><span title="257 discussions" class="Number">257</span></span></span> XML Development</a></li>
<li class="ClearFix Heading Category-classifieds"><span class="Aside"><span class="Count"><span title="3,313 discussions" class="Number">3.3K</span></span></span> Classifieds</li>
<li class="ClearFix Depth2 Category-coopprojects"><a href="http://programmersheaven.com/categories/coopprojects" class="ItemLink"><span class="Aside"><span class="Count"><span title="200 discussions" class="Number">200</span></span></span> Co-operative Projects</a></li>
<li class="ClearFix Depth2 Category-forsale"><a href="http://programmersheaven.com/categories/forsale" class="ItemLink"><span class="Aside"><span class="Count"><span title="198 discussions" class="Number">198</span></span></span> For sale</a></li>
<li class="ClearFix Depth2 Category-freelancesoftcity"><a href="http://programmersheaven.com/categories/freelancesoftcity" class="ItemLink"><span class="Aside"><span class="Count"><span title="190 discussions" class="Number">190</span></span></span> FreeLance Software City</a></li>
<li class="ClearFix Depth2 Category-jobs-available"><a href="http://programmersheaven.com/categories/jobs-available" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,913 discussions" class="Number">1.9K</span></span></span> Jobs Available</a></li>
<li class="ClearFix Depth2 Category-jobs-wanted"><a href="http://programmersheaven.com/categories/jobs-wanted" class="ItemLink"><span class="Aside"><span class="Count"><span title="603 discussions" class="Number">603</span></span></span> Jobs Wanted</a></li>
<li class="ClearFix Depth2 Category-wanted"><a href="http://programmersheaven.com/categories/wanted" class="ItemLink"><span class="Aside"><span class="Count"><span title="209 discussions" class="Number">209</span></span></span> Wanted</a></li>
<li class="ClearFix Heading Category-microsoft-net"><span class="Aside"><span class="Count"><span title="2,885 discussions" class="Number">2.9K</span></span></span> Microsoft .NET</li>
<li class="ClearFix Depth2 Category-aspnet"><a href="http://programmersheaven.com/categories/aspnet" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,751 discussions" class="Number">1.8K</span></span></span> ASP.NET</a></li>
<li class="ClearFix Depth2 Category-dotnet"><a href="http://programmersheaven.com/categories/dotnet" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,134 discussions" class="Number">1.1K</span></span></span> .NET General</a></li>
<li class="ClearFix Depth3 Category-dotnetwebservices"><a href="http://programmersheaven.com/categories/dotnetwebservices" class="ItemLink"><span class="Aside"><span class="Count"><span title="22 discussions" class="Number">22</span></span></span> .NET WEB-Services</a></li>
<li class="ClearFix Depth3 Category-dotnetwinforms"><a href="http://programmersheaven.com/categories/dotnetwinforms" class="ItemLink"><span class="Aside"><span class="Count"><span title="129 discussions" class="Number">129</span></span></span> .NET WinForms</a></li>
<li class="ClearFix Depth3 Category-dotnetxml"><a href="http://programmersheaven.com/categories/dotnetxml" class="ItemLink"><span class="Aside"><span class="Count"><span title="14 discussions" class="Number">14</span></span></span> .NET XML</a></li>
<li class="ClearFix Depth3 Category-dotnetadonet"><a href="http://programmersheaven.com/categories/dotnetadonet" class="ItemLink"><span class="Aside"><span class="Count"><span title="50 discussions" class="Number">50</span></span></span> ADO.NET</a></li>
<li class="ClearFix Depth3 Active Category-csharpschool"><a href="http://programmersheaven.com/categories/csharpschool" class="ItemLink"><span class="Aside"><span class="Count"><span title="144 discussions" class="Number">144</span></span></span> C# &amp; VB.NET School Support</a></li>
<li class="ClearFix Heading Category-miscellaneous"><span class="Aside"><span class="Count"><span title="3,370 discussions" class="Number">3.4K</span></span></span> Miscellaneous</li>
<li class="ClearFix Depth2 Category-join-the-team"><a href="http://programmersheaven.com/categories/join-the-team" class="ItemLink"><span class="Aside"><span class="Count"><span title="4 discussions" class="Number">4</span></span></span> Join the Team</a></li>
<li class="ClearFix Depth2 Category-pheaven"><a href="http://programmersheaven.com/categories/pheaven" class="ItemLink"><span class="Aside"><span class="Count"><span title="354 discussions" class="Number">354</span></span></span> Comments on this site</a></li>
<li class="ClearFix Depth2 Category-emulation"><a href="http://programmersheaven.com/categories/emulation" class="ItemLink"><span class="Aside"><span class="Count"><span title="69 discussions" class="Number">69</span></span></span> Computer Emulators</a></li>
<li class="ClearFix Depth2 Category-general"><a href="http://programmersheaven.com/categories/general" class="ItemLink"><span class="Aside"><span class="Count"><span title="2,135 discussions" class="Number">2.1K</span></span></span> General programming</a></li>
<li class="ClearFix Depth2 Category-languages"><a href="http://programmersheaven.com/categories/languages" class="ItemLink"><span class="Aside"><span class="Count"><span title="187 discussions" class="Number">187</span></span></span> New programming languages</a></li>
<li class="ClearFix Depth2 Category-offtopic"><a href="http://programmersheaven.com/categories/offtopic" class="ItemLink"><span class="Aside"><span class="Count"><span title="621 discussions" class="Number">621</span></span></span> Off topic board</a></li>
<li class="ClearFix Heading Category-mobile-wireless"><span class="Aside"><span class="Count"><span title="200 discussions" class="Number">200</span></span></span> Mobile &amp; Wireless</li>
<li class="ClearFix Depth2 Category-android"><a href="http://programmersheaven.com/categories/android" class="ItemLink"><span class="Aside"><span class="Count"><span title="72 discussions" class="Number">72</span></span></span> Android</a></li>
<li class="ClearFix Depth2 Category-palm"><a href="http://programmersheaven.com/categories/palm" class="ItemLink"><span class="Aside"><span class="Count"><span title="126 discussions" class="Number">126</span></span></span> Palm Pilot</a></li>
<li class="ClearFix Heading Category-multimedia"><span class="Aside"><span class="Count"><span title="338 discussions" class="Number">338</span></span></span> Multimedia</li>
<li class="ClearFix Depth2 Category-demo"><a href="http://programmersheaven.com/categories/demo" class="ItemLink"><span class="Aside"><span class="Count"><span title="154 discussions" class="Number">154</span></span></span> Demo programming</a></li>
<li class="ClearFix Depth2 Category-mp3"><a href="http://programmersheaven.com/categories/mp3" class="ItemLink"><span class="Aside"><span class="Count"><span title="184 discussions" class="Number">184</span></span></span> MP3 programming</a></li>
<li class="ClearFix Heading Category-operating-systems-platforms"><span class="Aside"><span class="Count"><span title="6,934 discussions" class="Number">6.9K</span></span></span> Operating Systems &amp; Platforms</li>
<li class="ClearFix Depth2 Category-bash-scripts"><a href="http://programmersheaven.com/categories/bash-scripts" class="ItemLink"><span class="Aside"><span class="Count"><span title="0 discussions" class="Number">0</span></span></span> Bash scripts</a></li>
<li class="ClearFix Depth2 Category-cloud"><a href="http://programmersheaven.com/categories/cloud" class="ItemLink"><span class="Aside"><span class="Count"><span title="27 discussions" class="Number">27</span></span></span> Cloud Computing</a></li>
<li class="ClearFix Depth3 Category-witsbits-go-cloud"><a href="http://programmersheaven.com/categories/witsbits-go-cloud" class="ItemLink"><span class="Aside"><span class="Count"><span title="1 discussion" class="Number">1</span></span></span> Witsbits Go Cloud</a></li>
<li class="ClearFix Depth2 Category-embedded"><a href="http://programmersheaven.com/categories/embedded" class="ItemLink"><span class="Aside"><span class="Count"><span title="365 discussions" class="Number">365</span></span></span> Embedded / RTOS</a></li>
<li class="ClearFix Depth2 Category-freebsd"><a href="http://programmersheaven.com/categories/freebsd" class="ItemLink"><span class="Aside"><span class="Count"><span title="53 discussions" class="Number">53</span></span></span> FreeBSD</a></li>
<li class="ClearFix Depth2 Category-linux"><a href="http://programmersheaven.com/categories/linux" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,679 discussions" class="Number">1.7K</span></span></span> LINUX programming</a></li>
<li class="ClearFix Depth3 Category-awk-scripting"><a href="http://programmersheaven.com/categories/awk-scripting" class="ItemLink"><span class="Aside"><span class="Count"><span title="1 discussion" class="Number">1</span></span></span> Awk scripting</a></li>
<li class="ClearFix Depth3 Category-linuxsupport"><a href="http://programmersheaven.com/categories/linuxsupport" class="ItemLink"><span class="Aside"><span class="Count"><span title="332 discussions" class="Number">332</span></span></span> Linux Support</a></li>
<li class="ClearFix Depth3 Category-sed-scripting"><a href="http://programmersheaven.com/categories/sed-scripting" class="ItemLink"><span class="Aside"><span class="Count"><span title="0 discussions" class="Number">0</span></span></span> Sed scripting</a></li>
<li class="ClearFix Depth2 Category-ms-dos"><a href="http://programmersheaven.com/categories/ms-dos" class="ItemLink"><span class="Aside"><span class="Count"><span title="370 discussions" class="Number">370</span></span></span> MS-DOS</a></li>
<li class="ClearFix Depth2 Category-shell-scripting"><a href="http://programmersheaven.com/categories/shell-scripting" class="ItemLink"><span class="Aside"><span class="Count"><span title="0 discussions" class="Number">0</span></span></span> Shell scripting</a></li>
<li class="ClearFix Depth2 Category-pocket-pc"><a href="http://programmersheaven.com/categories/pocket-pc" class="ItemLink"><span class="Aside"><span class="Count"><span title="321 discussions" class="Number">321</span></span></span> Windows CE &amp; Pocket PC</a></li>
<li class="ClearFix Depth2 Category-windows"><a href="http://programmersheaven.com/categories/windows" class="ItemLink"><span class="Aside"><span class="Count"><span title="4,119 discussions" class="Number">4.1K</span></span></span> Windows programming</a></li>
<li class="ClearFix Depth3 Category-com"><a href="http://programmersheaven.com/categories/com" class="ItemLink"><span class="Aside"><span class="Count"><span title="177 discussions" class="Number">177</span></span></span> COM/DCOM</a></li>
<li class="ClearFix Depth3 Category-networks"><a href="http://programmersheaven.com/categories/networks" class="ItemLink"><span class="Aside"><span class="Count"><span title="61 discussions" class="Number">61</span></span></span> Networking And Security</a></li>
<li class="ClearFix Depth3 Category-win2003server"><a href="http://programmersheaven.com/categories/win2003server" class="ItemLink"><span class="Aside"><span class="Count"><span title="17 discussions" class="Number">17</span></span></span> Windows 2003 Server</a></li>
<li class="ClearFix Depth3 Category-vista"><a href="http://programmersheaven.com/categories/vista" class="ItemLink"><span class="Aside"><span class="Count"><span title="6 discussions" class="Number">6</span></span></span> Windows Vista</a></li>
<li class="ClearFix Depth3 Category-winxp"><a href="http://programmersheaven.com/categories/winxp" class="ItemLink"><span class="Aside"><span class="Count"><span title="176 discussions" class="Number">176</span></span></span> Windows XP</a></li>
<li class="ClearFix Heading Category-software-development"><span class="Aside"><span class="Count"><span title="941 discussions" class="Number">941</span></span></span> Software Development</li>
<li class="ClearFix Depth2 Category-algorithms"><a href="http://programmersheaven.com/categories/algorithms" class="ItemLink"><span class="Aside"><span class="Count"><span title="417 discussions" class="Number">417</span></span></span> Algorithms</a></li>
<li class="ClearFix Depth2 Category-objects"><a href="http://programmersheaven.com/categories/objects" class="ItemLink"><span class="Aside"><span class="Count"><span title="68 discussions" class="Number">68</span></span></span> Object Orientation</a></li>
<li class="ClearFix Depth3 Category-uml"><a href="http://programmersheaven.com/categories/uml" class="ItemLink"><span class="Aside"><span class="Count"><span title="24 discussions" class="Number">24</span></span></span> RUP &amp; UML</a></li>
<li class="ClearFix Depth2 Category-projects"><a href="http://programmersheaven.com/categories/projects" class="ItemLink"><span class="Aside"><span class="Count"><span title="92 discussions" class="Number">92</span></span></span> Project Management</a></li>
<li class="ClearFix Depth2 Category-quality"><a href="http://programmersheaven.com/categories/quality" class="ItemLink"><span class="Aside"><span class="Count"><span title="95 discussions" class="Number">95</span></span></span> Quality &amp; Testing</a></li>
<li class="ClearFix Depth2 Category-security"><a href="http://programmersheaven.com/categories/security" class="ItemLink"><span class="Aside"><span class="Count"><span title="268 discussions" class="Number">268</span></span></span> Security</a></li>
<li class="ClearFix Depth3 Category-evilscripting"><a href="http://programmersheaven.com/categories/evilscripting" class="ItemLink"><span class="Aside"><span class="Count"><span title="63 discussions" class="Number">63</span></span></span> Evil Scripting</a></li>
<li class="ClearFix Depth3 Category-hacking"><a href="http://programmersheaven.com/categories/hacking" class="ItemLink"><span class="Aside"><span class="Count"><span title="81 discussions" class="Number">81</span></span></span> Hacking</a></li>
<li class="ClearFix Heading Category-web-development"><span class="Aside"><span class="Count"><span title="7,674 discussions" class="Number">7.7K</span></span></span> WEB-Development</li>
<li class="ClearFix Depth2 Category-aspfaq"><a href="http://programmersheaven.com/categories/aspfaq" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,758 discussions" class="Number">1.8K</span></span></span> Active Server Pages</a></li>
<li class="ClearFix Depth2 Category-ajax"><a href="http://programmersheaven.com/categories/ajax" class="ItemLink"><span class="Aside"><span class="Count"><span title="61 discussions" class="Number">61</span></span></span> AJAX</a></li>
<li class="ClearFix Depth2 Category-bootsrap-themes"><a href="http://programmersheaven.com/categories/bootsrap-themes" class="ItemLink"><span class="Aside"><span class="Count"><span title="4 discussions" class="Number">4</span></span></span> Bootstrap Themes</a></li>
<li class="ClearFix Depth2 Category-cgi"><a href="http://programmersheaven.com/categories/cgi" class="ItemLink"><span class="Aside"><span class="Count"><span title="55 discussions" class="Number">55</span></span></span> CGI Development</a></li>
<li class="ClearFix Depth2 Category-coldfusion"><a href="http://programmersheaven.com/categories/coldfusion" class="ItemLink"><span class="Aside"><span class="Count"><span title="28 discussions" class="Number">28</span></span></span> ColdFusion</a></li>
<li class="ClearFix Depth2 Category-flash"><a href="http://programmersheaven.com/categories/flash" class="ItemLink"><span class="Aside"><span class="Count"><span title="224 discussions" class="Number">224</span></span></span> Flash development</a></li>
<li class="ClearFix Depth2 Category-html"><a href="http://programmersheaven.com/categories/html" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,412 discussions" class="Number">1.4K</span></span></span> HTML &amp; WEB-Design</a></li>
<li class="ClearFix Depth2 Category-internet"><a href="http://programmersheaven.com/categories/internet" class="ItemLink"><span class="Aside"><span class="Count"><span title="1,426 discussions" class="Number">1.4K</span></span></span> Internet Development</a></li>
<li class="ClearFix Depth3 Category-mobileinternet"><a href="http://programmersheaven.com/categories/mobileinternet" class="ItemLink"><span class="Aside"><span class="Count"><span title="131 discussions" class="Number">131</span></span></span> Mobile Internet &amp; Messaging</a></li>
<li class="ClearFix Depth3 Category-wireless"><a href="http://programmersheaven.com/categories/wireless" class="ItemLink"><span class="Aside"><span class="Count"><span title="211 discussions" class="Number">211</span></span></span> Wireless development</a></li>
<li class="ClearFix Depth2 Category-java-script"><a href="http://programmersheaven.com/categories/java-script" class="ItemLink"><span class="Aside"><span class="Count"><span title="2,215 discussions" class="Number">2.2K</span></span></span> JavaScript</a></li>
<li class="ClearFix Depth2 Category-jquery"><a href="http://programmersheaven.com/categories/jquery" class="ItemLink"><span class="Aside"><span class="Count"><span title="37 discussions" class="Number">37</span></span></span> JQuery</a></li>
<li class="ClearFix Depth2 Category-other-web-servers"><a href="http://programmersheaven.com/categories/other-web-servers" class="ItemLink"><span class="Aside"><span class="Count"><span title="304 discussions" class="Number">304</span></span></span> WEB Servers</a></li>
<li class="ClearFix Depth3 Category-apache"><a href="http://programmersheaven.com/categories/apache" class="ItemLink"><span class="Aside"><span class="Count"><span title="153 discussions" class="Number">153</span></span></span> Apache</a></li>
<li class="ClearFix Depth3 Category-iis"><a href="http://programmersheaven.com/categories/iis" class="ItemLink"><span class="Aside"><span class="Count"><span title="79 discussions" class="Number">79</span></span></span> IIS</a></li>
<li class="ClearFix Depth2 Category-web-services"><a href="http://programmersheaven.com/categories/web-services" class="ItemLink"><span class="Aside"><span class="Count"><span title="150 discussions" class="Number">150</span></span></span> WEB-Services / SOAP</a></li>
        </ul>
    </div>
<div data-ns="rectangle"></div>
            </div>
                    </div>
    </div>
    <footer>
        <div class="Container">
            <div class="Row footer">
                <div class="col-6">
                    <a href="#" id="back-to-top" title="Back to top"><i class="icon icon-chevron-up"></i></a>

                    &copy; 2022 Copyright
                </div>
                <div class="col-6 right-text">

                </div>
            </div>
        </div>
        
    </footer>
<div id="search">
    <button class="modal-close"></button>
    <form method="get" action="/search">
<div>
<input type="text" id="Form_Search" name="Search" value="" placeholder="Search" accesskey="/" class="InputBox" /><input type="submit" id="Form_Go" name="" value="Go" class="Button" />
</div>
</form>
</div>
<div id="mobile-menu">
    <button class="modal-close"></button>
    <ul>
        <li><a href="/discussions" class="">Discussions</a></li>
        <li><a href="/categories" class="">Categories</a></li>
        
        
        
        
        
        <li><a href="/entry/signin" rel="nofollow" class="SignInPopup">Sign In</a></li>
    </ul>
</div>


 <script>
 $('body').show();
 $('.version').text(NProgress.version);
 NProgress.start();
 setTimeout(function() { NProgress.done(); $('.fade').removeClass('out'); }, 1000);
 </script>
 
</body>
</html>