I need help with DOS commands.

Hello, I am in need of some assistance with trying to get my fist ruby program to run. I am reading the book "Learn to program by chris pine" and he seems to be using a different DOS version them me. I think hes on a mac or using an XP version. His says version is "Microsoft Windows XP [Version 5.1.2600] 1985-2001 Microsoft Corp. I am running windows 7, my version is 6.1.7601 2009. Anyways the commands that he is telling me are not adding up. I tried the ruby -v to see if ruby was installed and the error I got was that it was not recognized in dos as an internal or external command? When I tried to go to the programs folder dos says it can't find it. When I saved my calc.rb file and tried to run it with ruby calc.rb DOS didn't recognize the command ether. I was in the correct directory. What could be the issue?


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


In this Discussion