Ouch Vista

Bought new machine with Vista
Bought new Visual Studio 2008 IDE

I'm trying an example from a WROX book and the code compiled, but would not run.
Found file was read only and tried to change it to 'not read only' and when I looked at the file properties again it was read only. I tried to delete it and dialog said I didn't have the permissions for that.

Copied it to the desktop and did all those steps again with the same results.

My apology for asking for help, but I'm really a Mac/Unix/linux coder and I'm trying to learn the Windows side and I'm not sure how to fix this permissions thing.

I'm spending the weekend at Lynda.com doing the Windows Vista Essential training to see if I can find this, but maybe one of you Vista Masters can help me sooner.

Many Thanks


  • I'm not sure if I understand what you mean. Are you trying to change the read-only property through Windows explorer or through the API function SetFileAttributes()?

    In case of the former, you are off-topic. In case of the latter, could you please post the code?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


In this Discussion