Stand alone EXE

this is not my first time to build a stand alone .exe, I did it many time but this time there is a strange problem.

when you compile and run your program under default options, every thing goes OK, but if you tried to make it stand alone .exe this error message appears and program stops compiling.
"[Linker Error] Unresolved external '__fastcall Filectrl::SelectDirectory(System::AnsiString&, System::Set, int)' referenced from C:PROGRAM FILESBORLANDCBUILDER6PROJECTSIMAGEMAIN.OBJ"

Steps I followed to make my project stand alone:
1- Linker Tab: Uncheck "Use dynamic RTL."
2- Linker Tab: Uncheck "Create debug information."
3- Packager Tab: Uncheck "Build with runtime packages."

thanx in advance,
Nasim

Comments

  • I browsed the Internet for five minutes and found an answer. I put it in the CodePedia: http://www.codepedia.com/1/CppBuilderLinkingErrors.

    If it still does not work, try browsing yourself. I hope you might put that wisdom on the CodePedia as well. See ya,


    bilderbikkel

  • : I browsed the Internet for five minutes and found an answer. I put it in the CodePedia: http://www.codepedia.com/1/CppBuilderLinkingErrors.
    :
    : If it still does not work, try browsing yourself. I hope you might put that wisdom on the CodePedia as well. See ya,
    :
    :
    : bilderbikkel
    :
    :
    thankx, but it didn't work.
    Also, i wanna determine the problem more and more:
    if you uncheck "Use dynamic RTL" every thing is OK
    if you uncheck "Build with runtime packages" Problem occures.

  • If you want, you can send me your entire project and I'll try to fix it. Then I'll put the results on CodePedia and reply to you. I won't comment you on coding style, nor will I copy your code :-)

    If you would like to, please send the minimal project files zipped to richelbilderbeek et fastmail.fm (notice the spam protection with typo).

    See ya,
    bilderbikkel

  • : If you want, you can send me your entire project and I'll try to fix it. Then I'll put the results on CodePedia and reply to you. I won't comment you on coding style, nor will I copy your code :-)
    :
    : If you would like to, please send the minimal project files zipped to richelbilderbeek et fastmail.fm (notice the spam protection with typo).
    :
    : See ya,
    : bilderbikkel
    :
    :
    Thank you Mr:bilderbikkel
  • Hi Luckyboy,

    it is fixed. The answer WAS on the CodePedia, so please read the link I send you next time and TRY it yourself. All I needed to do was to add a DriveComboBox (from the Win 3.11 Tab in the Component Palette) to your Form and delete it. Easy :-)

    See ya,
    bilderbikkel

  • [b][red]This message was edited by luckyboy at 2006-7-24 2:12:39[/red][/b][hr]
    : Hi Luckyboy,
    :
    : it is fixed. The answer WAS on the CodePedia, so please read the link I send you next time and TRY it yourself. All I needed to do was to add a DriveComboBox (from the Win 3.11 Tab in the Component Palette) to your Form and delete it. Easy :-)
    :
    : See ya,
    : bilderbikkel
    :
    :
    Thanx, but do you realise that it is a strange thing to put something then delete it ?!!! :(
    i read about its side effect, but i wouldn't be able to discover this without your help.
    thanx alot :)


  • : Thanx, but do you realise that it is a strange thing to put something then delete it ?!!! :(
    : i read about its side effect, but i wouldn't be able to discover this without your help.
    Yes it is 'strange', but why not try it if it might work...

    See ya,
    bilderbikkel

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories