Problem with porting of Linux code to Windows, FORTRAN/C.


There is a Linux console tool (written in FORTRAN/C) which I want to port under Windows. It can be started with one parameter:

$gribprint gfs1.grib

Example output on the console:

rec GRIB Lvl Lvl Lvl Time Fcst
Num Code Code one two hour
1 11 1 0 0 2005-10-11_00:00 +00

I have success with the compilation of the program under Windows. If I run it without argument it works fine and displays a help message. But if I run it with an argument (gfs1.grib) it starts to read the file and then it gives error message (it says that error log is created but I can't find it, W2K). The file is ok. I'm wondering where is the problem and I guess that it's in the file:


where are the I/O (read & write) functions. Here are the original sources for UNIX/Linux:

Thanks for any ideas!

Best Regards,



  • For sure I am very fresh to your Linux environment.
    But I have heard that the file system in Windows and Linux are not the same. They are different. I hope its ext2 or something for Linux.
    Is there anything that this can do.
    I m sorry if I am not right, for I am new to Linux.

    With regards,
    P.Guru Vinayak

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


In this Discussion