PCMCIA Parallel issues

I'm trying to write a program to interface with a simple device I made (pretty much a RAM chip hooked into a parallel port), and it requires the use of the bidirectional parallel port. I only have a PCMCIA parallel card, and so far, using it for SPP unidirectional transfers, it's fine. Everything works perfectly. However, setting bit 5 of the CR causes all data registers to jump to 0xFF. After reading the documentation, I see that I need to set the ECP Control Registers high three bits to "001", but I can't get access to them. The port's base address is 0xFFE8. I am using Windows XP, but that's not the problem; I'm using WinIO and I can get access to all SPP registers. I've tried writing to port 0x03EA (0xFFE8 + 0x0402), and I've tried reassigning the ports to just about everything under the sun. Nothing seems to work. Anyone know what's going on? It's a Quatech SPP-100.

Comments

  • Hi, I`m Arnaldo from Argentina. I`m doing some proyect at the University, I need to write (program) the output of the parallel port. The problem is that I need to run this program in a laptop (notebook) because this proyect must be portable.
    As you can imagine the laptop doesn
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

In this Discussion