Problem in debugging (Step into F11)


This is the problem thats occuring:

In the Solution I have, I have 2 projects - one is a Windows Application - and the second is a C# DLL file that has functions and classes defined. The Windows form calls a function in the C# file, when a button is clicked in the form.

I am trying to debug this function. Single step debug using Step into (From Debug menu) or F11 as the shortcut. However, when I hit F11 to step into the function, .NET will not go and allow me to debug the funtion one line at a time. It will not go to the function in the C# DLL at all, but rather behaves as if I hit "Step Over F10" and proceeds to next line of code in windows form without going to the C# DLL.

I have the reference of the C# Dll in the Windows app. Also tried putting Break points in the C# DLL. But inspite of the breakpoints, it will not single step in the C# code, but move over to next line in the windows app.

Is there a setting? I am connected to Source safe for this solution and all files are checked out. Even tried working disconnected but same problem. I do not think its a .NET install problem because for other locally created projects, the debug feature works ok...

Please suggest some ways out of this crazyiness.

Saumil Annegiri,
Research Assistant,
Center for Business and Information Technologies,
ULLafayette, LA
ph. # 337-654-8660

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!