8086 assembler problem



I have a header file called "ass1h" and have defined it like #include "ass1.h". I have created a program that turns the mouse on and then off. However the dos and bois interupts are in the header file. When i try and run the program i get two errors:

Undefined symbol Show_Cursor
Undefined symbol Mouse_Int

However Show_Cursor and Mouse_Int are in the header file. Anyone have any other reason why these errors occur.

Please help

*Ribbleton_

Comments

  • : I have a header file called "ass1h" and have defined it like #include "ass1.h". I have created a program that turns the mouse on and then off. However the dos and bois interupts are in the header file. When i try and run the program i get two errors:
    :
    : Undefined symbol Show_Cursor
    : Undefined symbol Mouse_Int

    The errors appear to be saying that the assembler has not found anything with those labels to attach an address to.
    It's like the proc's arn't included at all.
    Included improperly maybe.
    Undefined may mean that you have to define any externals you're using?

    What assembler are you using ?
    Have you tried other included procedures and had them work before,
    or is this your first time at this?
    Use trial and error & simplify stuff untill it works?
    Have you got a small code snipit to lay on us?


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

In this Discussion