kylix on redhat 73

I am using redhat 73 and I want to install kylix2.
but as most of the people who tried before can know a libc problem.
I dont know the problem because when I use the tool to test the system for chechk it says ok for libc but when I tried to install it says that libc dependency failed .
What can I do to install?(or is it possible)

ozgur

Comments

  • : I am using redhat 73 and I want to install kylix2.
    : but as most of the people who tried before can know a libc problem.
    : I dont know the problem because when I use the tool to test the system for chechk it says ok for libc but when I tried to install it says that libc dependency failed .
    : What can I do to install?(or is it possible)
    :
    : ozgur
    :

    I have only experience with K1,
    so this may not work with K2...

    If you look at the files created when you unpacked
    the Kylix install program, you should find a directory
    somewhere that contains the *.rpm files.

    Maybe it is "./setup.data/packages/" ?

    Change (cd) into that directory.

    Then install the RPM's manually.
    Maybe something like this...
    ( using bash as root ):

    export KY_DIR=/usr/local/kylix
    mkdir $KY_DIR
    for RPM in *.rpm
    do
    rpm -U --nodeps --prefix $KY_DIR $RPM
    done


    Note that if you do not use the "--prefix" option,
    you may end up with kylix files scattered all over
    your system!
    - I found that out the hard way !
    ;-)


    If you still get libc errors when you run kylix,
    you probably need to upgrade your libraries.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

In this Discussion