Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

can't get cdrom & floppy to mount

HudasceneHudascene Member Posts: 10
I installed Mandrake 8.1 on my 'puter, and the cdrom worked fine for the install, but now the bootup log (dmesg)is telling me that it detects the cdrom (TATUNG CD-1216E DVD/CD-ROM drive) but that when it goes to mount the device, it displays the following:

hdd: command error: status 0x51 { DriveReady SeekComplete Error }
hdd: command error: error=0x50
end_request: I/O error, dev 16:40 (hdd) sector 0

It does this twice, and then shows the following:

MSDOS FS: IO charset iso8859-1
MSDOS FS: using codepage 850
hdd: command error: status 0x51 { DriveReady SeekComplete Error }
hdd: command error: error=0x50
end_request: I/O error, dev 16:40 (hdd) sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=iso8859-1

It tries this several times, then gives up. Can anyone tell me what is going on here? Do I need to change the fstab entry for the cdrom and floppy, and if so to what? Or do I need to alter the kernel somehow? It's driving me nuts. I thought I was supposed to be able to log in as root and mount the drives and make them available upon bootup, but I can't figure out how. Any help would be greatly appreciated!
Hudascene

Comments

  • DuckDodgersDuckDodgers Member Posts: 1
    : I installed Mandrake 8.1 on my 'puter, and the cdrom worked fine for the install, but now the bootup log (dmesg)is telling me that it detects the cdrom (TATUNG CD-1216E DVD/CD-ROM drive) but that when it goes to mount the device, it displays the following:
    :
    : hdd: command error: status 0x51 { DriveReady SeekComplete Error }
    : hdd: command error: error=0x50
    : end_request: I/O error, dev 16:40 (hdd) sector 0
    :
    : It does this twice, and then shows the following:
    :
    : MSDOS FS: IO charset iso8859-1
    : MSDOS FS: using codepage 850
    : hdd: command error: status 0x51 { DriveReady SeekComplete Error }
    : hdd: command error: error=0x50
    : end_request: I/O error, dev 16:40 (hdd) sector 0
    : FAT: unable to read boot sector
    : FAT: freeing iocharset=iso8859-1
    :
    : It tries this several times, then gives up. Can anyone tell me what is going on here? Do I need to change the fstab entry for the cdrom and floppy, and if so to what? Or do I need to alter the kernel somehow? It's driving me nuts. I thought I was supposed to be able to log in as root and mount the drives and make them available upon bootup, but I can't figure out how. Any help would be greatly appreciated!
    : Hudascene
    :
    :

  • jeffpostjeffpost Member Posts: 316
    I am not a Linux guru, but it looks like you've set up the system to auto mount the cdrom at bootup and you have no disk in the drive.

    /etc/fstab should have entries such as the following:

    /dev/fd0 /mnt/floppy auto noauto,user 0 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0

    You then can mount them from the command line with

    mount /mnt/cdrom

    or from KDE or Gnome by right clicking on the device icon and selecting 'mount'.

    Hope this helps.

  • paladinpaladin Member Posts: 97
    : I installed Mandrake 8.1 on my 'puter, and the cdrom worked fine for the install, but now the bootup log (dmesg)is telling me that it detects the cdrom (TATUNG CD-1216E DVD/CD-ROM drive) but that when it goes to mount the device, it displays the following:
    :
    : hdd: command error: status 0x51 { DriveReady SeekComplete Error }
    : hdd: command error: error=0x50
    : end_request: I/O error, dev 16:40 (hdd) sector 0
    :
    : It does this twice, and then shows the following:
    :
    : MSDOS FS: IO charset iso8859-1
    : MSDOS FS: using codepage 850
    : hdd: command error: status 0x51 { DriveReady SeekComplete Error }
    : hdd: command error: error=0x50
    : end_request: I/O error, dev 16:40 (hdd) sector 0
    : FAT: unable to read boot sector
    : FAT: freeing iocharset=iso8859-1
    :
    : It tries this several times, then gives up. Can anyone tell me what is going on here? Do I need to change the fstab entry for the cdrom and floppy, and if so to what? Or do I need to alter the kernel somehow? It's driving me nuts. I thought I was supposed to be able to log in as root and mount the drives and make them available upon bootup, but I can't figure out how. Any help would be greatly appreciated!
    : Hudascene
    :
    :
    You have to have bootable "media" in the drive, otherwise you will get an error. This is the case for both manual mounting of the device or doing so on boot up. I always manually mount my floppies and cdrom devices. One word of advice to you, make sure you manually unmount the device before pulling any floppies out of the drive, or you will loose everything on the floppy. I am not sure, but the same thing may occur on a writeable cdrom.
Sign In or Register to comment.