Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

DLL not working

hitesh_kapadiahitesh_kapadia Member Posts: 6
Hello,

I have created a DLL file in which I have written 2 functions. From my ASP page, I am creating the instance of the DLL & using the functions as methods. My first function works but the second function doesn't work. It doesn't even show any errors but the processing is never done.

Please help me.

Thanks
Hitesh

Comments

  • mich5mich5 Member Posts: 4
    The first thing you have to double-check is if your in-proc COM server (i.e. DLL) has been properly registered. It is possible that there is an old version of your COM object registered (during the implementation, was there a moment when your DLL has a single method? :)
    Typically you register your DLL as regsvr32 your_dll.dll

    In case it does not help, I should see your code (youe can cut off all the functionality, staying empty methods only)

    : Hello,
    :
    : I have created a DLL file in which I have written 2 functions. From my ASP page, I am creating the instance of the DLL & using the functions as methods. My first function works but the second function doesn't work. It doesn't even show any errors but the processing is never done.
    :
    : Please help me.
    :
    : Thanks
    : Hitesh
    :


  • hitesh_kapadiahitesh_kapadia Member Posts: 6
    Hi,

    Thanks very much for the reply. Now I am able to access the methods in the DLL. I just changed the calling order of the methods & it has started working. Anyway thanks for ur help.

    Hitesh


    : The first thing you have to double-check is if your in-proc COM server (i.e. DLL) has been properly registered. It is possible that there is an old version of your COM object registered (during the implementation, was there a moment when your DLL has a single method? :)
    : Typically you register your DLL as regsvr32 your_dll.dll
    :
    : In case it does not help, I should see your code (youe can cut off all the functionality, staying empty methods only)
    :
    : : Hello,
    : :
    : : I have created a DLL file in which I have written 2 functions. From my ASP page, I am creating the instance of the DLL & using the functions as methods. My first function works but the second function doesn't work. It doesn't even show any errors but the processing is never done.
    : :
    : : Please help me.
    : :
    : : Thanks
    : : Hitesh
    : :
    :
    :


Sign In or Register to comment.