Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

Damn you Borland!

In Borland, I am attempting to compile some directX 8.0 stuff that I got from Microsoft's web site. Under the Options/Project
It allows me to specify the directory for the includes and libs. Good ol Borland only allows you to use one directory of includes and not two at a time. I need to use the standard libarays like in the borland directory, AND the includes in the DirectX SDK directory. Do I have to write out the full file name of every directx include i'm using or is borland just hiding the solution from me?

VC++ allows me to overcome this problem easily, but sadly i dont have a copy right now.

Comments

  • AsmGuru62AsmGuru62 Posts: 6,519Member
    Have you tried this?
    c:folder1dir1;d:folder2dir2;e:folder3dir3


  • DanTheRockerDanTheRocker Posts: 95Member
    : Have you tried this?
    : c:folder1dir1;d:folder2dir2;e:folder3dir3
    :
    :
    Good work!
    It works....better.

    I'm wondering now why i get an odd error. Im using Tutorial 2 in the Directx sdk. To be specific:DirectX SDKsamplesMultimediaDirect3DTutorialsTut02_Vertices

    All I've done is created a project and added the one source file to it. When I compile i get a linker error:

    [code]
    Info :Linking D:DirectX SDKsamplesMultimediaDirect3DTutorialsTut02_Verticesverticies.exe
    Error: Error: Unresolved external 'Direct3DCreate8' referenced from D:DIRECTX SDKSAMPLESMULTIMEDIADIRECT3DTUTORIALSTUT02_VERTICESVERTICES.OBJ[/code]

    What do I have to do to fix this?


  • AlienripperAlienripper Posts: 133Member
    I don't know about Borland, but with MSVC++ that error means you haven't included right libraries..

Sign In or Register to comment.