Using DirectDraw on device emulator (Platform Builder 6.0 R3) - Programmers Heaven

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Using DirectDraw on device emulator (Platform Builder 6.0 R3)

Hi all, I'm new to this group and new to winCE development.

I'm planning to develop a simple direct draw application for my device. For developing and early tests I'm using the device emulator

coming with platform builder. My problem is that ddraw sample applications (ddex1, ddex2, ...) don't run on device emulator.

In fact, as I try to run a sample, the execution stops immediately because DirectDrawCreate fails with a return value of E_FAIL


My platform: Visual Studio 2005 with Platform Builder 6.0 R3;
In catalog I've selected DirectDraw, Minimal GDI Configuration, and Minimal GWES Configuration.

The debug log is:
4294914038 PID:2a7000e TID:2a8000e Failed to retrieve DirectDraw ApiSet address (ordinal 2.)
4294914041 PID:2a7000e TID:2a8000e Unable to initialize GWES hook object. DirectDraw is disabled.
4294914071 PID:400002 TID:2a8000e AddToProcessInputLocaleTable: Added process to ProcessInputLocale table, hProcess = 0x02A7000E
4294914914 PID:2a7000e TID:2a8000e DirectDraw is disabled. No GWES hook object! DirectDrawCreate fails.
4294915158 PID:400002 TID:2a8000e DlgMgr: FindDlgItem id 1 returning NULL.
4294915609 PID:400002 TID:391000a ERROR: D:Dublin2-2privatewinceosCOREOSgwewinmgrwmbase.wbase.cpp line 1337:
4294915613 PID:400002 TID:391000a !bFound, etc.
4294929677 PID:2a7000e TID:2a8000e DDEX1: DirectDrawCreate FAILED, hRet=-2147467259

Any hints to get it work ?

Thank you in advance.


Sign In or Register to comment.