etmp4 and tcl please help URGENT! - Programmers Heaven

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

etmp4 and tcl please help URGENT!

vessyvessy Posts: 1Member
I am trying to create a video file by the command exec ./etmp4 -p -0 sd_1 rd_1 st_a01 a01.mp4 a01e in a tcl script.

but, when I run it- the video files weren't created by the tcl script.

When I tried to run it from the console the video files were created,but with the output "aborted" in the end:

[b]~/ns-allinone-2.34/ns-2.34/v1$ ./etmp4 -p -0 sd_1 rd_1 st_a01 a01.mp4 a01e

*** loss_a01e.txt ***: percentage of lost [frames|packets]
column 1: I (including H)
column 2: P
column 3:
column 2: loss flag
column 3: end-to-end delay [s]
column 4: sender inter [frame|packet] lag [s]
column 5: receiver inter [frame|packet] lag [s]
column 6: cumulative jitter [s] [Hartanto et. al.]

*** rate_s_a01e.txt ***: sender rate
column 1: time [s]
column 2: momentary rate [bytes/s]
column 3: cumulative rate [bytes/s]

*** rate_r_a01e.txt ***: receiver rate
column 1: time [s]
column 2: momentary rate [bytes/s]
column 3: cumulative rate [bytes/s]

*** glibc detected *** ./etmp4: double free or corruption (fasttop): 0x080b9b88 ***
======= Backtrace: =========

======= Memory map: ========
08048000-080b0000 r-xp 00000000 08:01 2974088 /home/celtro/ns-allinone-2.34/ns-2.34/v1/etmp4
080b0000-080b1000 rw-p 00067000 08:01 2974088 /home/celtro/ns-allinone-2.34/ns-2.34/v1/etmp4

080b1000-080f0000 rw-p 080b1000 00:00 0 [heap]
b7a00000-b7a21000 rw-p b7a00000 00:00 0
b7a21000-b7b00000 ---p b7a21000 00:00 0
b7bcb000-b7bd5000 r-xp 00000000 08:01 65600 /lib/
b7bd5000-b7bd6000 rw-p 0000a000 08:01 65600 /lib/
b7be4000-b7e28000 rw-p b7be4000 00:00 0
b7e28000-b7f71000 r-xp 00000000 08:01 82947 /lib/tls/i686/cmov/
b7f71000-b7f72000 r--p 00149000 08:01 82947 /lib/tls/i686/cmov/
b7f72000-b7f74000 rw-p 0014a000 08:01 82947 /lib/tls/i686/cmov/
b7f74000-b7f77000 rw-p b7f74000 00:00 0
b7f77000-b7f9a000 r-xp 00000000 08:01 82951 /lib/tls/i686/cmov/
b7f9a000-b7f9c000 rw-p 00023000 08:01 82951 /lib/tls/i686/cmov/
b7fa7000-b7fac000 rw-p b7fa7000 00:00 0
b7fac000-b7fad000 r-xp b7fac000 00:00 0 [vdso]
b7fad000-b7fc7000 r-xp 00000000 08:01 67847 /lib/
b7fc7000-b7fc9000 rw-p 00019000 08:01 67847 /lib/
bfac9000-bfade000 rw-p bffeb000 00:00 0 [stack]
Aborted [/b]

do you know why it is different in the tcl via the console?
and what is the problem in the console, why I got this error?
Sign In or Register to comment.