Error in .sh files while running on windows - Programmers Heaven

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

Error in .sh files while running on windows

HumaZeeshanHumaZeeshan Posts: 2Member
Hi all

I want to run the file having extension .sh on windows and i have installed cygwin and some of my sh files are running perfectly but if i run the file having following code:


"D:/sentenceclassifier/TrainTest" -n "All_Features" $1 $2 > t_a_.arff;

"D:/sentenceclassifier/TrainTest" -l LemmaSorted.txt -n "All_L" $1 $2 > t_a_l.arff;
"D:/sentenceclassifier/TrainTest" -l LemmaSorted.txt -p 31 -z -n "All_L_P31_Z" $1 $2 > t_a_l_p31_z.arff;

"D:/sentenceclassifier/TrainTest" -l LemmaSorted.txt -p 31 -z -u -n "All_L_P31_Z_U" $1 $2 > t_a_p31_z_u.arff;
"D:/sentenceclassifier/TrainTest" -l LemmaSorted.txt -s my-stop-list -n "All_L_S" $1 $2 > t_a_l_s.arff;

"D:/sentenceclassifier/TrainTest" -p 31 -z -n "All_P31_Z" $1 $2 > t_a_p31_z.arff;

"D:/sentenceclassifier/TrainTest" -p 31 -z -u -n "All_P31_Z_U" $1 $2 > t_a_p31_z_u.arff;

"D:/sentenceclassifier/TrainTest" -s my-stop-list -n "All_Stopwords" $1 $2 > t_a_s.arff;

"D:/sentenceclassifier/TrainTest" -z -n "All_Z" $1 $2 > t_a_z.arff;[/color][/color]

and executing it as:
bash corpus_only_dataset
it gives error
bash.exe warning could not find /temp please create! D:sentenceclassifierTrainTest is a directory

Can any one help to solve the problem by let me know what i m doing wrong... Urgent help please!!!!!!!!!!!!!!!!




  • HumaZeeshanHumaZeeshan Posts: 2Member

    I have solved the problem the mistake i was doing is not setting path for cygwin/bin so it could not find the file bash.exe

Sign In or Register to comment.