Combo Box problem. - Programmers Heaven

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Combo Box problem.

toddlerasimtoddlerasim Posts: 93Member
I have been trying to get a Combo Box to accept integers via a FOR loop. Since the Combo accepts only strings I converted the integers into a string using the itoa() function and sent the appropriate messages. However, what I am getting in the Combo are beautifully designed squares instead of the integers as converted to a string. What could I be possibly doing wrong. Two other Combos I filled in using a struct are working perfectly. While on this I would like to know if the atoi() function returns only a signed integer?

Comments

  • AsmGuru62AsmGuru62 Posts: 6,519Member
    [color=Blue]Check if your code is UNICODE oriented. Because itoa() works with ANSI buffers only.[/color]
  • toddlerasimtoddlerasim Posts: 93Member
    I don't see anything even resembling the word UNICODE in my coding. I am using VS@))* and the O.S. is XP Professional. If itoa() is used for just ANSI buffers then what do we use for UNICODE?
  • toddlerasimtoddlerasim Posts: 93Member
    This posting has been deleted.
  • AsmGuru62AsmGuru62 Posts: 6,519Member
    [color=Blue]itow() can be used, also windows API has wsprintf() which properly maps to ANSI or UNICODE version.[/color]
  • toddlerasimtoddlerasim Posts: 93Member
    Thanks for the function. I used itow_s() and it worked like a charm.

    Regards.
Sign In or Register to comment.