Ruby on Rails in Windows 2000 - Programmers Heaven

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

Ruby on Rails in Windows 2000

iesies Posts: 6Member
Hello Everyone,

I am new to using Ruby as our first project will opt to use it. I was trying to run Ruby using the InstantRails. But when I started to launch the application and tried to update the gem, some error occured.

after i issued the command: gem update --system, the error below appeared.

ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
getaddrinfo: temporary failure in name resolution. (SocketError)
getting size of

Please, I need some help on how to overcome this one.

Thanks a lot.


  • jay102jay102 Posts: 1Member
    This is also my problem. If you have any idea please share with us. Thank you very much!!!!!!!!!!!!
  • iesies Posts: 6Member

    I have long been away from ruby and just last night I had the flame for learning it again. I followed a different installation procedure and succeeded. I never used that gem command anymore, and it worked. But another problem occurred. It has something to do with the ruby script/server command. I can't fix it.

    the command:

    ruby script/server

    results to:

    ruby: No such file or directory -- script/server (LoadError)
Sign In or Register to comment.