Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Firewall Issue

Malcolm2008Malcolm2008 Member Posts: 20
Hello

I have created a program in Visual Studio 2008 (in VB.Net), and have found that if I change the Company in "My Project->Application->Assembly Information", from "Microsoft", to my own business name that Trend Micro Internet Security decides to display a warning with the "Allow" or "Block" options which suggest my program looks suspicious.

Not sure if other firewalls do the same thing.

Does anyone know how I can change the company to my own business name and avoid my customers thinking my software is suspicious.

Thank you

Comments

  • Malcolm2008Malcolm2008 Member Posts: 20
    Sorry about the double up, the page looked as though it didn't send properly.
  • seancampbellseancampbell Pennsylvania, USAMember Posts: 684 ✭✭✭
    Does your software access the network or the internet? Sounds like it does. As far as I know, there is nothing you can do about those messages. When I write software for a client, I usually explain to them that their firewall protects them by blocking traffic to the internet from software that it does not recognize. This doesn't mean that the software is malicious, in fact most malicious softwares don't give that prompt.

    If I see anything about this, I will be sure to update this forum post.
  • Malcolm2008Malcolm2008 Member Posts: 20
    Thanks for your response.

    I do agree that it does sound like I won't be able to do anything about it. In case someone knows of something I will explain the internet situation with my program

    Except for a couple of unlikely causes mentione further on, the software does not access the internet, at least from the point where I can actually use the debugger and my own code runs. Maybe there is a bit of Microsoft inserted code that runs before My Code runs. Reason I say that is that it was origianlly using the Click Once setup, and the program checked for updates before the program actually loaded. I am now using a different setup program, and not using it as a click once program. I have now Turned off Click once security, and also set the program not to check for updates before hand, so unless I have missed a setting somewhere I can't see that it is using the internet at all. My program is designed for offline use, apart from the following:

    It does have an activation system that accesses the internet via http, port 80 using a web browser. It is however in another exe file. So I also assume this is not the issue.

    Also in another exe file is online access to update the program. The main exe file in question does reference the update control for the purpose of making sure it is included with my setup program, but I have unreferenced this file to see if it is causing the issue and it isn't

    Bottom line is I have already ruled out everything I can see that is accessing the internet, and all internet access is in another exe file, except the reference the main exe file still has to the update object (which has been ruled out anyway).

    The only thing I have been able to find is Set Company in Assembly Details to Microsoft, and the Trend Micro doesn't complain. Change it to my own business name and Trend Micro Complains. Seems to be something to do with the fact I am a unknown publisher.

    Having said all that the details I get in the Trend Micro Message seem to suggest an internet issue. It says something about TCP Port Number ? (Port number changes every time).




  • Malcolm2008Malcolm2008 Member Posts: 20
    Just found the answer to this just now. I'm sure others will run into this problem, so thought I would supply the answer to save others the hours it took me to solve it.

    If you have the following combination of settings set you will run into problems with Trend Micro Internet Security and maybe other firewall software telling your user that your software is suspicious with a warning that the program is High Risk.

    Note: These settings are all in your Project Properties

    1) Click on Application Tab, and click on Assembly Information and Change "Company" to anything but "Microsoft" and Click on OK.
    2) Check "Make Single Instance Application"

    If you do this you will have the trouble when running the program by double clicking the exe in Explorer. To duplicate the problem while in Visual Basic, you will also need to go to Debug Tab and unselect "Enable the Visual Studio Hosting Process

    Bottom line is to fix the problem you need to unselect "Make Single Instance Application" and all will be well
Sign In or Register to comment.