Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

how to compile and run a tcl script in ns-2

Hello all,

I am new to linux & ns-2 simulator. I am using RedHat 9.0 and ns-2.33. I got a code for ad-hoc routing and tried running it giving command "tclsh" and my file name, but it gave error as:

invalid command name new
while executing
"new Simulator"
invoked from within "set ns_ [new Simulator]"

can anybody plz help me with this? Am I using the wrong command? I just wrote this code and tried running it. Am I supposed to write anything else in any other file? What is the command to compile? and to execute?

This is very urgent. Plz help

Thanks
Sign In or Register to comment.