Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

Make CPPB6 IDE background opaque (hide desktop)

Alex QuinnAlex Quinn Posts: 1Member
I'm totally new to Borland C++ Builder. I'm using version 6. I'm irritated because whatever apps are behind the IDE always show through. Basically, the UI is like a Mac application, not a Windows application. I want to maximize the window and not have to see anything that's behind it.

Is there a way to fix this? Is there some reason why I should just get used to it?

Thanks,
Alex

Comments

  • BitByBit_ThorBitByBit_Thor Posts: 2,444Member
    : I'm totally new to Borland C++ Builder. I'm using version 6. I'm
    : irritated because whatever apps are behind the IDE always show
    : through. Basically, the UI is like a Mac application, not a Windows
    : application. I want to maximize the window and not have to see
    : anything that's behind it.
    :

    Don't know the IDE, but there's probably an 'Options' dialog somewhere. Look for opaqueness/transparency. If you really can't find it, you could check the official website for help on where to find the option. Or wait for someone where who does know the IDE first hand.

    : Is there a way to fix this? Is there some reason why I should just
    : get used to it?
    :

    So you can aw at the technological beauty of it all ;)
    Best Regards,
    Richard

    The way I see it... Well, it's all pretty blurry
  • bilderbikkelbilderbikkel Posts: 754Member
    : I'm totally new to Borland C++ Builder. I'm using version 6. I'm
    : irritated because whatever apps are behind the IDE always show
    : through. Basically, the UI is like a Mac application, not a Windows
    : application. I want to maximize the window and not have to see
    : anything that's behind it.
    :
    : Is there a way to fix this? Is there some reason why I should just
    : get used to it?
    :
    : Thanks,
    : Alex

    If you don't want to see your window, do

    [code]
    this->Hide();
    [/code]

    or

    [code]
    this->Visible = false;
    [/code]

    For half-opaque windows, set AlphaBlend to true and the AlphaValue (or something alike) to 128.

    See ya,

    bilderbikkel
Sign In or Register to comment.