Lost button in IDE - Programmers Heaven

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Lost button in IDE

Hello all,

I have some how lost one of my buttons in my ide. Actually I haven't lost the button...the one that adds a new form to the project. The button is there but the glyph is gone and the button no longer adds the new form. Is there a ini file or something that I need to adjust? Any help would be appreciated.

Thanks

James

Comments

  • zibadianzibadian Posts: 6,349Member
    : Hello all,
    :
    : I have some how lost one of my buttons in my ide. Actually I haven't lost the button...the one that adds a new form to the project. The button is there but the glyph is gone and the button no longer adds the new form. Is there a ini file or something that I need to adjust? Any help would be appreciated.
    :
    : Thanks
    :
    : James
    :
    Try customizing the toolbars. Just right-click the toolbar, and then you should be able to add that button again. If that button doesn't behave normally, then it appears that your Delphi has become corrupt and you might need to reinstall it.
  • jamesb800jamesb800 Posts: 105Member
    : : Hello all,
    : :
    : : I have some how lost one of my buttons in my ide. Actually I haven't lost the button...the one that adds a new form to the project. The button is there but the glyph is gone and the button no longer adds the new form. Is there a ini file or something that I need to adjust? Any help would be appreciated.
    : :
    : : Thanks
    : :
    : : James
    : :
    : Try customizing the toolbars. Just right-click the toolbar, and then you should be able to add that button again. If that button doesn't behave normally, then it appears that your Delphi has become corrupt and you might need to reinstall it.
    :

    Thanks Z, I tried all that. Didn't work. Time to break out the install disk.

    James

  • jamesb800jamesb800 Posts: 105Member
    : : : Hello all,
    : : :
    : : : I have some how lost one of my buttons in my ide. Actually I haven't lost the button...the one that adds a new form to the project. The button is there but the glyph is gone and the button no longer adds the new form. Is there a ini file or something that I need to adjust? Any help would be appreciated.
    : : :
    : : : Thanks
    : : :
    : : : James
    : : :
    : : Try customizing the toolbars. Just right-click the toolbar, and then you should be able to add that button again. If that button doesn't behave normally, then it appears that your Delphi has become corrupt and you might need to reinstall it.
    : :
    :
    : Thanks Z, I tried all that. Didn't work. Time to break out the install disk.
    :
    : James
    :
    :

    OK....I found an easier way to fix this problem then reinstalling the program. Maybe this is what zibadian meant but, in any case, if anyone else ever has this problem, I fixed it like this.

    1. Left click on offending button. In my case it was the "New Form" button on the View toolbar.

    2. Drag it off the IDE thus eliminating it.

    3. Right click on toolbar and select "Customize"

    4. Select "File" from the Categories listbox.

    5. In the "Commands" listbox, right click the Forms icon and drag it to the "View" toolbar.

    That's it. Didn't have to go through the headache of reinstall.


    James

  • zibadianzibadian Posts: 6,349Member
    : : : : Hello all,
    : : : :
    : : : : I have some how lost one of my buttons in my ide. Actually I haven't lost the button...the one that adds a new form to the project. The button is there but the glyph is gone and the button no longer adds the new form. Is there a ini file or something that I need to adjust? Any help would be appreciated.
    : : : :
    : : : : Thanks
    : : : :
    : : : : James
    : : : :
    : : : Try customizing the toolbars. Just right-click the toolbar, and then you should be able to add that button again. If that button doesn't behave normally, then it appears that your Delphi has become corrupt and you might need to reinstall it.
    : : :
    : :
    : : Thanks Z, I tried all that. Didn't work. Time to break out the install disk.
    : :
    : : James
    : :
    : :
    :
    : OK....I found an easier way to fix this problem then reinstalling the program. Maybe this is what zibadian meant but, in any case, if anyone else ever has this problem, I fixed it like this.
    :
    : 1. Left click on offending button. In my case it was the "New Form" button on the View toolbar.
    :
    : 2. Drag it off the IDE thus eliminating it.
    :
    : 3. Right click on toolbar and select "Customize"
    :
    : 4. Select "File" from the Categories listbox.
    :
    : 5. In the "Commands" listbox, right click the Forms icon and drag it to the "View" toolbar.
    :
    : That's it. Didn't have to go through the headache of reinstall.
    :
    :
    : James
    :
    :
    That was exactly what I meant.
  • jamesb800jamesb800 Posts: 105Member
    : : : : : Hello all,
    : : : : :
    : : : : : I have some how lost one of my buttons in my ide. Actually I haven't lost the button...the one that adds a new form to the project. The button is there but the glyph is gone and the button no longer adds the new form. Is there a ini file or something that I need to adjust? Any help would be appreciated.
    : : : : :
    : : : : : Thanks
    : : : : :
    : : : : : James
    : : : : :
    : : : : Try customizing the toolbars. Just right-click the toolbar, and then you should be able to add that button again. If that button doesn't behave normally, then it appears that your Delphi has become corrupt and you might need to reinstall it.
    : : : :
    : : :
    : : : Thanks Z, I tried all that. Didn't work. Time to break out the install disk.
    : : :
    : : : James
    : : :
    : : :
    : :
    : : OK....I found an easier way to fix this problem then reinstalling the program. Maybe this is what zibadian meant but, in any case, if anyone else ever has this problem, I fixed it like this.
    : :
    : : 1. Left click on offending button. In my case it was the "New Form" button on the View toolbar.
    : :
    : : 2. Drag it off the IDE thus eliminating it.
    : :
    : : 3. Right click on toolbar and select "Customize"
    : :
    : : 4. Select "File" from the Categories listbox.
    : :
    : : 5. In the "Commands" listbox, right click the Forms icon and drag it to the "View" toolbar.
    : :
    : : That's it. Didn't have to go through the headache of reinstall.
    : :
    : :
    : : James
    : :
    : :
    : That was exactly what I meant.
    :

    That's what I figured. Thanks Z.

    James
Sign In or Register to comment.