Sql Bind Error - Programmers Heaven

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Sql Bind Error

hi frndz,

I got this error while insert the records in to table.
it show in execut query.


Error Type:
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[MySQL][ODBC 3.51 Driver][mysqld-5.0.18-nt]SQLBindParameter not used for all parameters
/admin/dbnewuser1.asp, line 87

Coding:

qry = "insert into usercreat (userid ,userpass,hint_qus,hint_ans,user_name,user_gender,user_dob,user_marital,user_addr1,user_addr2,user_addr3,city,state,country,zipcode,email,work_phone,home_phone,cellno,type,status) values '"&um_id&"' ,'"&um_pass&"','"&um_hintqus&"' ,'"&um_hintans&"' ,'"&um_name&"','"&um_gender&"','"&um_dob&"','"&um_marital&"','"&um_address1&"','"&um_address2&"','"&um_address3&"','"&um_city&"','"&um_state&"','"&um_country&"','"&um_pincode&"','"&um_email&"','"&um_workphone&"','"&um_homephone&"','"&um_cellno&"','U','A' )"

this is my query.

you help is very urgent to me




Comments

  • Frames84Frames84 Posts: 7Member
    : hi frndz,
    :
    : I got this error while insert the records in to table.
    : it show in execut query.
    :
    :
    : Error Type:
    : Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
    : [MySQL][ODBC 3.51 Driver][mysqld-5.0.18-nt]SQLBindParameter not used for all parameters
    : /admin/dbnewuser1.asp, line 87
    :
    : Coding:
    :
    : qry = "insert into usercreat (userid ,userpass,hint_qus,hint_ans,user_name,user_gender,user_dob,user_marital,user_addr1,user_addr2,user_addr3,city,state,country,zipcode,email,work_phone,home_phone,cellno,type,status) values '"&um_id&"' ,'"&um_pass&"','"&um_hintqus&"' ,'"&um_hintans&"' ,'"&um_name&"','"&um_gender&"','"&um_dob&"','"&um_marital&"','"&um_address1&"','"&um_address2&"','"&um_address3&"','"&um_city&"','"&um_state&"','"&um_country&"','"&um_pincode&"','"&um_email&"','"&um_workphone&"','"&um_homephone&"','"&um_cellno&"','U','A' )"
    :
    : this is my query.
    :
    : you help is very urgent to me
    :
    :
    :
    :
    :

    I think you might have to put [ ] round your column names i.e.
    INSERT INTO Table ([userId], [col]) Values('2', 'somedata')

    Maybe someone else might help.

    *Frames84_
Sign In or Register to comment.