Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

Removing a Database record

mombawombamombawomba Posts: 30Member
I am working on a simple application that uses a data set. The data set and commands were all generated by Visual Studio 2003. The database is one that I created in Access 2003. Everything works except the DELETE command. My code looks like this:

[code]
private void btnRemoveCust_Click(object sender, System.EventArgs e)
{
// Get the current records position
int rowNumber = this.BindingContext[dataSet11, "Customer"].Position;

// Delete the record
dataSet11.Tables["Customer"].Rows[rowNumber].Delete();

// Accept the change
dataSet11.AcceptChanges();
oleDbDataAdapter1.Update(dataSet11, "Customer");
}
[/code]

The problem is that after I run this handler and look at the table nothing has been removed.

I've been looking all over the internet and can't find anything that will tell me if this will even work. Am I doing it right or is there something I'm missing?

Thanks

Comments

Sign In or Register to comment.