Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

What the...???

GaashiusGaashius Member Posts: 349
Hi everyone!

I'm almost at the end of my newest game. When I want to test the new level I made for it:

1) it quits and says I should send an error report to Microsoft.....
2) The screen goes to blue with white text for a few hundred millisecs, and then the comp RESTARTS!

Number 1 appears just before the level begins ( so after main menu ).
Number 2 appears while playing.

What the heck can make this? I'm out of ideas. I only use the following Delphi-inculded units: sysutils,windows,registry,shellapi. I use DirectX tech also.

I have worked a lot on this project, about since 20 days, I don't want this work to throw out to the trash!! Who can help please do so.... if can't please tell what should I tell to make you able to help me better.

Gaashius

****************

[b][blue]GAASHIUS[/blue][/b]

Comments

  • zibadianzibadian Member Posts: 6,349
    : Hi everyone!
    :
    : I'm almost at the end of my newest game. When I want to test the new level I made for it:
    :
    : 1) it quits and says I should send an error report to Microsoft.....
    : 2) The screen goes to blue with white text for a few hundred millisecs, and then the comp RESTARTS!
    :
    : Number 1 appears just before the level begins ( so after main menu ).
    : Number 2 appears while playing.
    :
    : What the heck can make this? I'm out of ideas. I only use the following Delphi-inculded units: sysutils,windows,registry,shellapi. I use DirectX tech also.
    :
    : I have worked a lot on this project, about since 20 days, I don't want this work to throw out to the trash!! Who can help please do so.... if can't please tell what should I tell to make you able to help me better.
    :
    : Gaashius
    :
    : ****************
    :
    : [b][blue]GAASHIUS[/blue][/b]
    :
    :
    Based on this I would say that the initialization of the level leaves one of the windows subsystems, most likely DirectX, in an unstable state. Which results in the famous "blue screen of death". More than this I cannot tell you, because I don't know your code, the values of the new level, etc.
    My suggestion is: step through the initialization to find the precise statement, which generates the initial error. Once you have that, try to figure out, which part of the new level causes the problem, and then find a solution for it.
Sign In or Register to comment.