PHP and Apache - Programmers Heaven

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

PHP and Apache

mac_doggiemac_doggie Posts: 488Member
Hi,

Can anyone tell me how to configure Apache 4.1 or 5.0 so I can use PHP ?
In Apache 1.3 there was a httpd.conf file, but I can't seem to find that in 4.1 and 5.0 anymore...

hope someone can help me out here...


;-)
-mac-
mailto:mac_doggie@hotmail.com
the Netherlands...

Comments

  • netgertnetgert Posts: 331Member
    : Hi,
    :
    : Can anyone tell me how to configure Apache 4.1 or 5.0 so I can use PHP ?
    : In Apache 1.3 there was a httpd.conf file, but I can't seem to find that in 4.1 and 5.0 anymore...
    :
    : hope someone can help me out here...
    :
    :
    : ;-)
    : -mac-
    : mailto:mac_doggie@hotmail.com
    : the Netherlands...
    :
    :
    4.1? 5.0? There is no such Apache version (the latest is 2.0). To get PHP 4.1 or 5.0 work in Apache 1.3, use the same steps as with other PHP versions
    Your text is really confusing
    [hr][red][italic][b]N[/b][/red][blue]et[/blue][red][b]G[/b][/red][blue]ert[/italic][/blue][hr]

  • mac_doggiemac_doggie Posts: 488Member
    : : Hi,
    : :
    : : Can anyone tell me how to configure Apache 4.1 or 5.0 so I can use PHP ?
    : : In Apache 1.3 there was a httpd.conf file, but I can't seem to find that in 4.1 and 5.0 anymore...
    : :
    : : hope someone can help me out here...
    : :
    : :
    : : ;-)
    : : -mac-
    : : mailto:mac_doggie@hotmail.com
    : : the Netherlands...
    : :
    : :
    : 4.1? 5.0? There is no such Apache version (the latest is 2.0). To get PHP 4.1 or 5.0 work in Apache 1.3, use the same steps as with other PHP versions
    : Your text is really confusing
    : [hr][red][italic][b]N[/b][/red][blue]et[/blue][red][b]G[/b][/red][blue]ert[/italic][/blue][hr]
    :
    :


    I downloaded Apache 5.0 at least that's what I thought. It seems to be Apache 2.0 Tomcat 5.0 (I don't know the difference between apache and tomcat.. could you explain this ?

    I finaly downloaded apache 1.3 wich does have an httpd.conf file, so php now works fine, I only don't get MySQL to work prpoperly. I uncommented the extension=php_mysql.dll file in my php.ini but apperently this dll is nowhere to be found on my entire system... Doesn't this file supposed to be in the installation package of php ? or MySQL ...?


    ;-)
    -mac-
    mailto:mac_doggie@hotmail.com
    the Netherlands...


  • netgertnetgert Posts: 331Member
    : : : Hi,
    : : :
    : : : Can anyone tell me how to configure Apache 4.1 or 5.0 so I can use PHP ?
    : : : In Apache 1.3 there was a httpd.conf file, but I can't seem to find that in 4.1 and 5.0 anymore...
    : : :
    : : : hope someone can help me out here...
    : : :
    : : :
    : : : ;-)
    : : : -mac-
    : : : mailto:mac_doggie@hotmail.com
    : : : the Netherlands...
    : : :
    : : :
    : : 4.1? 5.0? There is no such Apache version (the latest is 2.0). To get PHP 4.1 or 5.0 work in Apache 1.3, use the same steps as with other PHP versions
    : : Your text is really confusing
    : : [hr][red][italic][b]N[/b][/red][blue]et[/blue][red][b]G[/b][/red][blue]ert[/italic][/blue][hr]
    : :
    : :
    :
    :
    : I downloaded Apache 5.0 at least that's what I thought. It seems to be Apache 2.0 Tomcat 5.0 (I don't know the difference between apache and tomcat.. could you explain this ?
    :
    : I finaly downloaded apache 1.3 wich does have an httpd.conf file, so php now works fine, I only don't get MySQL to work prpoperly. I uncommented the extension=php_mysql.dll file in my php.ini but apperently this dll is nowhere to be found on my entire system... Doesn't this file supposed to be in the installation package of php ? or MySQL ...?
    :
    :
    : ;-)
    : -mac-
    : mailto:mac_doggie@hotmail.com
    : the Netherlands...
    :
    :
    :
    with the new versions of PHP (4.3.x i guess) the mysql support is compiled-in (that is, if youre using precompiled windows version)
    all extensions should be in the extensions subfolder of php (can be changed in the ini file)
    the latest mysql version i could get working with my apache 1.3 & php 4.3.4 was mysql 4.0
    [hr][red][italic][b]N[/b][/red][blue]et[/blue][red][b]G[/b][/red][blue]ert[/italic][/blue][hr]

  • mac_doggiemac_doggie Posts: 488Member
    I downloaded jakarta tomcat and that was version 4 and version 5. I finally found apache version 1.3 and installed that, I now got it to work again. 1.3 does have a httpd.conf. jakarta tomcat 4 and 5 didn't so I didn't know how to get php to work there,

    thanx anyway...


    : : : : Hi,
    : : : :
    : : : : Can anyone tell me how to configure Apache 4.1 or 5.0 so I can use PHP ?
    : : : : In Apache 1.3 there was a httpd.conf file, but I can't seem to find that in 4.1 and 5.0 anymore...
    : : : :
    : : : : hope someone can help me out here...
    : : : :
    : : : :
    : : : : ;-)
    : : : : -mac-
    : : : : mailto:mac_doggie@hotmail.com
    : : : : the Netherlands...
    : : : :
    : : : :
    : : : 4.1? 5.0? There is no such Apache version (the latest is 2.0). To get PHP 4.1 or 5.0 work in Apache 1.3, use the same steps as with other PHP versions
    : : : Your text is really confusing
    : : : [hr][red][italic][b]N[/b][/red][blue]et[/blue][red][b]G[/b][/red][blue]ert[/italic][/blue][hr]
    : : :
    : : :
    : :
    : :
    : : I downloaded Apache 5.0 at least that's what I thought. It seems to be Apache 2.0 Tomcat 5.0 (I don't know the difference between apache and tomcat.. could you explain this ?
    : :
    : : I finaly downloaded apache 1.3 wich does have an httpd.conf file, so php now works fine, I only don't get MySQL to work prpoperly. I uncommented the extension=php_mysql.dll file in my php.ini but apperently this dll is nowhere to be found on my entire system... Doesn't this file supposed to be in the installation package of php ? or MySQL ...?
    : :
    : :
    : : ;-)
    : : -mac-
    : : mailto:mac_doggie@hotmail.com
    : : the Netherlands...
    : :
    : :
    : :
    : with the new versions of PHP (4.3.x i guess) the mysql support is compiled-in (that is, if youre using precompiled windows version)
    : all extensions should be in the extensions subfolder of php (can be changed in the ini file)
    : the latest mysql version i could get working with my apache 1.3 & php 4.3.4 was mysql 4.0
    : [hr][red][italic][b]N[/b][/red][blue]et[/blue][red][b]G[/b][/red][blue]ert[/italic][/blue][hr]
    :
    :

    ;-)
    -mac-
    mailto:mac_doggie@hotmail.com
    the Netherlands...


Sign In or Register to comment.