Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID

Categories

We have migrated to a new platform! Please note that you will need to reset your password to log in (your credentials are still in-tact though). Please contact lee@programmersheaven.com if you have questions.
Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

please help installing package

Hello All, I'm trying to install a rpm package but it is giving the "Failed Dependencies" error given as follows

error: Failed dependencies:
libkdecore.so.2 is needed by caitoo-0.6.6-1
libkdeui.so.2 is needed by caitoo-0.6.6-1
libkfile.so.2 is needed by caitoo-0.6.6-1
libkfm.so.2 is needed by caitoo-0.6.6-1
libmediatool.so.2 is needed by caitoo-0.6.6-1
libqt.so.1 is needed by caitoo-0.6.6-1

But I've searched these libraries & these are present on my system eg.

locate libkdecore | more
/usr/lib/kde2-compat/lib/libkdecore.so.3.0.0 /usr/lib/kde2-compat/lib/libkdecore.la /usr/lib/kde2-compat/lib/libkdecore.so /usr/lib/kde2-compat/lib/libkdecore.so.3 /usr/lib/libkdecore.so.3.0.0 /usr/lib/libkdecore.so.3 /usr/lib/libkdecore.so.4.1.0 /usr/lib/libkdecore.la /usr/lib/libkdecore.so /usr/lib/libkdecore.so.4

Now please tell me how to solve this problem. Why the package giving me this "Failed Dependencies" error message though the libraries it requires present on my machine. Please help. This problems occures with me in many rpm installations. Any sugeestions..... Please help.... Thanx in advance....

Comments

  • JonathanJonathan Posts: 2,914Member
    : Hello All, I'm trying to install a rpm package but it is giving the "Failed Dependencies" error given as follows
    :
    : error: Failed dependencies:
    : libkdecore.so.2 is needed by caitoo-0.6.6-1
    Note libkdecore.so.2 here

    : locate libkdecore | more
    : /usr/lib/kde2-compat/lib/libkdecore.so.3.0.0 /usr/lib/kde2-compat/lib/libkdecore.la /usr/lib/kde2-compat/lib/libkdecore.so /usr/lib/kde2-compat/lib/libkdecore.so.3 /usr/lib/libkdecore.so.3.0.0 /usr/lib/libkdecore.so.3 /usr/lib/libkdecore.so.4.1.0 /usr/lib/libkdecore.la /usr/lib/libkdecore.so /usr/lib/libkdecore.so.4
    :
    And not in this list. But maybe you do have the library, as I'd guess the .2 on the end suggests it's for KDE2. So how about doing:-

    cd /usr/lib/kde2-compat/lib
    ln libkdecore.so libkdecore.so.2

    No promises, but I've done this before and it's sometimes worked out.

    Jonathan

    ###
    for(74,117,115,116){$::a.=chr};(($_.='qwertyui')&&
    (tr/yuiqwert/her anot/))for($::b);for($::c){$_.=$^X;
    /(p.{2}l)/;$_=$1}$::b=~/(..)$/;print("$::a$::b $::c hack$1.");

  • madhur_ahujamadhur_ahuja Posts: 14Member
    : : Hello All, I'm trying to install a rpm package but it is giving the "Failed Dependencies" error given as follows
    : :
    : : error: Failed dependencies:
    : : libkdecore.so.2 is needed by caitoo-0.6.6-1
    : Note libkdecore.so.2 here
    :
    : : locate libkdecore | more
    : : /usr/lib/kde2-compat/lib/libkdecore.so.3.0.0 /usr/lib/kde2-compat/lib/libkdecore.la /usr/lib/kde2-compat/lib/libkdecore.so /usr/lib/kde2-compat/lib/libkdecore.so.3 /usr/lib/libkdecore.so.3.0.0 /usr/lib/libkdecore.so.3 /usr/lib/libkdecore.so.4.1.0 /usr/lib/libkdecore.la /usr/lib/libkdecore.so /usr/lib/libkdecore.so.4
    : :
    : And not in this list. But maybe you do have the library, as I'd guess the .2 on the end suggests it's for KDE2. So how about doing:-
    :
    : cd /usr/lib/kde2-compat/lib
    : ln libkdecore.so libkdecore.so.2
    :
    : No promises, but I've done this before and it's sometimes worked out.
    :
    : Jonathan
    :
    : ###
    : for(74,117,115,116){$::a.=chr};(($_.='qwertyui')&&
    : (tr/yuiqwert/her anot/))for($::b);for($::c){$_.=$^X;
    : /(p.{2}l)/;$_=$1}$::b=~/(..)$/;print("$::a$::b $::c hack$1.");
    :
    :

    Hello
    why not download a package manager like apt or yum and let the software download the dependencies for you.

    Madhur Ahuja
    Visit for self developed programs
    http://madhur.netfirms.com
    India

Sign In or Register to comment.