Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Apache configuration help

BridoBrido Member Posts: 2
I have been trying to get Apache to display my website through www.brido.co.uk, but not with much joy I am afraid.

On the local host it works fine. Trying and connect from outside of my network and it doesn't work. I am running XP, so I made sure the firewall is turned off (unticking the box in the advanced tab of the network properties). My router has no firewall running on it either. I ping my domain and it points to my router fine. I had an ftp server going (not apache) before so I know it forwards it on okay. Set my router to forward ports 8000 to my machine running apache.

In the httpd.conf file I have set the listen to 8000 and the servername to www.brido.co.uk:8000

When i try 127.0.0.1:8000 it is fine
Try www.brido.co.uk:8000 and I get page cannot be displayed. I have also had friends try, they have no luck (try yourselves, nowt!!)

Any ideas?? I am out and I don't have any experience in apache. I have also tried all the above with port 8080. Nuffin'!!

Any help would be appreciated.

Cheers

Comments

  • JonathanJonathan Member Posts: 2,914
    : I have been trying to get Apache to display my website through www.brido.co.uk, but not with much joy I am afraid.
    :
    : On the local host it works fine. Trying and connect from outside of my network and it doesn't work. I am running XP, so I made sure the firewall is turned off (unticking the box in the advanced tab of the network properties). My router has no firewall running on it either. I ping my domain and it points to my router fine. I had an ftp server going (not apache) before so I know it forwards it on okay. Set my router to forward ports 8000 to my machine running apache.
    :
    : In the httpd.conf file I have set the listen to 8000 and the servername to www.brido.co.uk:8000
    :
    : When i try 127.0.0.1:8000 it is fine
    : Try www.brido.co.uk:8000 and I get page cannot be displayed. I have also had friends try, they have no luck (try yourselves, nowt!!)
    :
    : Any ideas?? I am out and I don't have any experience in apache. I have also tried all the above with port 8080. Nuffin'!!
    :
    : Any help would be appreciated.
    :
    Hmmmm....your domain resolves to 62.3.225.136 - is that the IP address of your machine? I get connection refused errors. Just because you disabled your XP firewall doesn't mean something else is in the way - do you have a router somewhere?

    Jonathan

    ###
    for(74,117,115,116){$::a.=chr};(($_.='qwertyui')&&
    (tr/yuiqwert/her anot/))for($::b);for($::c){$_.=$^X;
    /(p.{2}l)/;$_=$1}$::b=~/(..)$/;print("$::a$::b $::c hack$1.");

  • BridoBrido Member Posts: 2
    : Hmmmm....your domain resolves to 62.3.225.136 - is that the IP address of your machine? I get connection refused errors. Just because you disabled your XP firewall doesn't mean something else is in the way - do you have a router somewhere?
    :
    : Jonathan

    Yeah, that is the IP address of my router, I have it forwarding TCP ports 80, 8080 and 8000 to my machine in my internal network. I did have FTP working fine and dandy, just HTTP is causing problems from external addresses.

    I am going to update my routers firmware over the weekend and see how that goes, I think there must be a problem with my router forwarding http but was just checking with the experts to see if I have missed anything in the apache setup. I have setup IIS and netware's HTTP server before (Forget it's name!!), but you know how these are, they like to wipe yer arse for you, so you get it working and you are non the wiser on seting up and configuring http servers!! :D

    Oh, almost forgot, I don't run any firewall software on my router nor inbetween my router and my http server.
  • JonathanJonathan Member Posts: 2,914
    : : Hmmmm....your domain resolves to 62.3.225.136 - is that the IP address of your machine? I get connection refused errors. Just because you disabled your XP firewall doesn't mean something else is in the way - do you have a router somewhere?
    : :
    : : Jonathan
    :
    : Yeah, that is the IP address of my router, I have it forwarding TCP ports 80, 8080 and 8000 to my machine in my internal network. I did have FTP working fine and dandy, just HTTP is causing problems from external addresses.
    :
    : I am going to update my routers firmware over the weekend and see how that goes, I think there must be a problem with my router forwarding http but was just checking with the experts to see if I have missed anything in the apache setup. I have setup IIS and netware's HTTP server before (Forget it's name!!), but you know how these are, they like to wipe yer arse for you, so you get it working and you are non the wiser on seting up and configuring http servers!! :D
    :
    : Oh, almost forgot, I don't run any firewall software on my router nor inbetween my router and my http server.
    :
    If you can run other web servers under the same conditions and it works then I'm happy this is an Apache config issue. So I won't talk about your network any more. :-)

    Next question would be do you anywhere in your configuration bind Apache to a particular hostname or IP address?

    Jonathan

    ###
    for(74,117,115,116){$::a.=chr};(($_.='qwertyui')&&
    (tr/yuiqwert/her anot/))for($::b);for($::c){$_.=$^X;
    /(p.{2}l)/;$_=$1}$::b=~/(..)$/;print("$::a$::b $::c hack$1.");

Sign In or Register to comment.