Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Configuring X Windows under RedHat 5.1



Hello,


I am very new to Linux and have been learning the commands in the bash shell. My problem is that I do not have X windows up and running. I bought the Linux Developers Kit, and it has X Windows on it( for Redhat and Debian)... but I can not seem to correctly configure it.


Also I cannot seem to invoke "make" from the command shell line.


Does anyone know an answer to my dilemna?


Sinc,


Jason




ps- does anyone know of a good How-To on the layout of the Linux system heirarchy? ( i.e. =kernel, drivers, consoles, servers... the way they behave under the Linux OS) thanks!


Comments

  • Hi! I am reletavelyh new to Linux too, but being extremely knowlegable about computers transferring from the Windowze world to Linux is no problem.


    It sounds like you have not installed a compiler not to be able to invoke make! How big is your hd? I had to exclude it on my second PC (100meg hdd)


    If you ain't got make, you ain't got nothing to run your PC with. Just about everything in a tar.gz file has to be compiled. I think (Im not totally sure, youd know) isnt The developers kit have accelerated-x or metro-x? If not, you can grab the rpm file off the 5.1 CD (Free-x), with rpm you don't need a compiler.


    What i'd recommend: If 5.1 is anythingh like 5.2, reboot your system with the install disk & cd and choose UPGRADE. Add any components (ie X and C & C++ compilers), and boom, they will be installed for you.


    I can't really say what is wrong you have not explained your problem adquately enough. Reply. Please?


    Ryan Verner

    (email me if you'd prefer)




    :

    : Hello,


    : I am very new to Linux and have been learning the commands in the bash shell. My problem is that I do not have X windows up and running. I bought the Linux Developers Kit, and it has X Windows on it( for Redhat and Debian)... but I can not seem to correctly configure it.


    : Also I cannot seem to invoke "make" from the command shell line.


    : Does anyone know an answer to my dilemna?


    : Sinc,


    : Jason


    :

    : ps- does anyone know of a good How-To on the layout of the Linux system heirarchy? ( i.e. =kernel, drivers, consoles, servers... the way they behave under the Linux OS) thanks!







  • Hi Ryan,


    I have two 4.3gig IDE hard drives (western) running on a 233 Pentium MMX and 32 megs ram, one 24x CD player on my main computer, and I installed Redhat on an old scrap 250 megabyte Western Digital IDE hd.


    I installed the Metro-X and development compilers that came with the system, but when I finished the installation and logged on, all I had was the "dos-like" shell. I tried to run Make from the command line, but it said that that file didn't exist. So I searched, and yes, it did exist under the usr/bin directory. but it still wouldn't run.


    Basically I have a command-line only Redhat 5.1 on a 250 mb western digital IDE drive. I still had about 42 megs for a swapping/paging partition and 20 or so megs left over.


    Can you tell me anything based on that? Maybe I don't understand Redhat's layout well enough. I've learned the basic UNIX commands though, am able to move, copy, etc. in the command-line... do a bit of Emacs... and I think I understand the basic layout of the filesystem. I just can't seem to get my video drivers configured and I can't seem to get Make to work.


    Thanks, hope that helped you any.


    Jason


  • Make should have been installed in the basic install, if not grab it off a redhat mirrior. (rpm style.)


    are you logged in as root when trying to 'make'?


    You should be able to 'startx', and run with the default config. How ever, if you do want to get more adventurous then 'Xconfigure', 'XF86config' or 'xconf" one of them gives you a ms-dos like gui, I think its the last one I forget.

    If you are going to do this, make sure you backup the original copy of your config (/etc/X11/XF86Config).


    If you are going on iRC or something of the like you will want to secure your box, RH5.1 runs imapd as default, to disable this, as root.

    [root@localhost ~]# pico /etc/inetd.conf

    (or use emacs/vi, heh).

    go down to the imap bit it will say like:


    imap steam root nowait /usr/sbin/tcpd imapd

    or something along those lines, this is from memory. heh.

    and just comment that out (with a #). Save /etc/inetd.conf

    Your prompt will return.


    [root@localhost ~]# killall -HUP inetd

    (restart the service)


    You might want to think about getting ssh and sshd, if you do so, disable telnet, rlogin, rsh, etc.


    well, that turned into a bit of a rant. heh.


    latez.


  • heh, always the way, after you post your message you realised you have forgotten something.

    when you type 'make' what does it say?


    also, you may need to run "./configure", as may packages have this script to make the Makefile (config file for 'make'.)


    -wait3r.


Sign In or Register to comment.