Database connection with Data Adapter Configuration Wizard - HELP

I am having a problem on a project that I am working on.
I am using C# to connect to a Access database that is running through MSDE.

I can set up a sqlDataApadter with no problem. It allows me to access the data. BUT the update command will not work. Here is the problem...
[code]http://students.cs.ua.edu/mdean/error.jpg[/code]
Follow the link to see a screenshot of my error.

Why can this not generate the Update command? I cannot find anything I am doing wrong. It is very critical that this work for my project.

PLEASE HELP - and thanks in advance for your help!

Later,
Matt


Comments

  • You need to set primary keys on your database tables... otherwise the Update and Delete statements cannot do their job... At least using VS.NET (I assume so, because I have had the exact same error message before!)...

    pheyze
  • : You need to set primary keys on your database tables... otherwise the Update and Delete statements cannot do their job... At least using VS.NET (I assume so, because I have had the exact same error message before!)...
    :
    : pheyze
    :
    That is my problem... I have primary keys set on the database, and it still doesn't work. I think it has something to do with MSDE, when it imports that data, it doesn't seem to identify the primary key.

    Matt
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories