Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Welcome to the new platform of Programmer's Heaven! We apologize for the inconvenience caused, if you visited us from a broken link of the previous version. The main reason to move to a new platform is to provide more effective and collaborative experience to you all. Please feel free to experience the new platform and use its exciting features. Contact us for any issue that you need to get clarified. We are more than happy to help you.

Can't debug on Web Server

rwbean86rwbean86 Posts: 7Member
I'm learning ASP.NET development and web development for the first time. I can't debug and run(F5) my ASP.NET projects in Visual Studio. When I try to I get a Microsoft Development Environment message which tells me that the "web server"(I assume it means IIS) "does not support debugging of ASP.NET server components". It then says that I should run setup or verify that a valid URL has been specified.

I've set "Enable ASP debugging" and "Enable ASP.NET Debugging to True in the project properties.
I have set up IIS several times now in an effort to fix this problem. I ran VS setup again and installed everything that wasn't installed the first time.

Do I need a different version of the IIS server?

Comments

  • hunterlsqhunterlsq Posts: 1Member
    Your IIS only support asp,and not support asp.net,
    IF you want to run asp.net,You must install dotnetfx.exe

  • pingpongpingpong Posts: 937Member
    Try this:

    - Control Panel/Administartive Tools/Computer Management.
    - Expand the Local Users and Groups/Users
    - Find the ASPNET account (should be there if you installed VS.NET).
    - Right click it/Properties/Member Of/Add and add "Debugger Users" and "VS Developers". To be honest, one of them is only needed but I cant remember which.
    - From the command line, iisreset and you should be good to go.

    Hope this fixes it for you.

    : I'm learning ASP.NET development and web development for the first time. I can't debug and run(F5) my ASP.NET projects in Visual Studio. When I try to I get a Microsoft Development Environment message which tells me that the "web server"(I assume it means IIS) "does not support debugging of ASP.NET server components". It then says that I should run setup or verify that a valid URL has been specified.
    :
    : I've set "Enable ASP debugging" and "Enable ASP.NET Debugging to True in the project properties.
    : I have set up IIS several times now in an effort to fix this problem. I ran VS setup again and installed everything that wasn't installed the first time.
    :
    : Do I need a different version of the IIS server?
    :
    :

  • rwbean86rwbean86 Posts: 7Member
    Thanks for your advice. I found that in spite of the fact that I installed VS.NET there was no ASPNET account. I uninstalled and installed again, and it still isn't there. When I follow you instructions I still get the message(exactly the same one). I must be doing something wrong as I install the software. I've put VS.NET on two other machines with no trouble at all. I'm confused. What is this account for? What does it allow you to do? I'm quite new to ASP/ASP.NET and IIS.

    : Try this:
    :
    : - Control Panel/Administartive Tools/Computer Management.
    : - Expand the Local Users and Groups/Users
    : - Find the ASPNET account (should be there if you installed VS.NET).
    : - Right click it/Properties/Member Of/Add and add "Debugger Users" and "VS Developers". To be honest, one of them is only needed but I cant remember which.
    : - From the command line, iisreset and you should be good to go.
    :
    : Hope this fixes it for you.
    :
    : : I'm learning ASP.NET development and web development for the first time. I can't debug and run(F5) my ASP.NET projects in Visual Studio. When I try to I get a Microsoft Development Environment message which tells me that the "web server"(I assume it means IIS) "does not support debugging of ASP.NET server components". It then says that I should run setup or verify that a valid URL has been specified.
    : :
    : : I've set "Enable ASP debugging" and "Enable ASP.NET Debugging to True in the project properties.
    : : I have set up IIS several times now in an effort to fix this problem. I ran VS setup again and installed everything that wasn't installed the first time.
    : :
    : : Do I need a different version of the IIS server?
    : :
    : :
    :
    :

  • rwbean86rwbean86 Posts: 7Member
    I'm also finding that on the machines where the debugging works I have a virtual directory called aspnet_client with some JScript files in its subdirectories.

    : Try this:
    :
    : - Control Panel/Administartive Tools/Computer Management.
    : - Expand the Local Users and Groups/Users
    : - Find the ASPNET account (should be there if you installed VS.NET).
    : - Right click it/Properties/Member Of/Add and add "Debugger Users" and "VS Developers". To be honest, one of them is only needed but I cant remember which.
    : - From the command line, iisreset and you should be good to go.
    :
    : Hope this fixes it for you.
    :

Sign In or Register to comment.