Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Question about SSI.

thaylinthaylin Member Posts: 2
What I am trying to figure out how to do is disable the part of SSI that will allow the execution of scripts without disabling any part of SSI. The only solution to this that I have come up with is to disable the addhandler for cgi scripts to run in the standard conf files and add them for just specific CGI-BIN's to use. Does anyone know how to directly disable SSI from being able to parse executables or another way to do this.

Comments

  • JonathanJonathan Member Posts: 2,914
    : What I am trying to figure out how to do is disable the part of SSI
    : that will allow the execution of scripts without disabling any part
    : of SSI. The only solution to this that I have come up with is to
    : disable the addhandler for cgi scripts to run in the standard conf
    : files and add them for just specific CGI-BIN's to use. Does anyone
    : know how to directly disable SSI from being able to parse executables
    : or another way to do this.

    Hi...yeah, I think what you need is the IncludesNOEXEC option. So where in your Apache .conf file you'd normally put Includes, just put IncludesNOEXEC instead, and it disables CGI execution by an include.

    Hope that works for you!

    Jonathan



    ------------------------------------------
    Count downloads from your site for free!
    http://www.downloadcounter.com/

  • thaylinthaylin Member Posts: 2
    : : What I am trying to figure out how to do is disable the part of SSI
    : : that will allow the execution of scripts without disabling any part
    : : of SSI. The only solution to this that I have come up with is to
    : : disable the addhandler for cgi scripts to run in the standard conf
    : : files and add them for just specific CGI-BIN's to use. Does anyone
    : : know how to directly disable SSI from being able to parse executables
    : : or another way to do this.
    :
    : Hi...yeah, I think what you need is the IncludesNOEXEC option. So where in your Apache .conf file you'd normally put Includes, just put IncludesNOEXEC instead, and it disables CGI execution by an include.
    :
    : Hope that works for you!
    :
    : Jonathan
    :
    :
    :
    : ------------------------------------------
    : Count downloads from your site for free!
    : http://www.downloadcounter.com/
    :
    :


    Thanks,
    I knew about that option and the problem was that subdomains will not work if the domain this was set in was above it. What will happen is that the server will nto be able to create the document root to the subdomain. In order for this to work all the domains have to be on the same level. I apologize I had edited my message putting that in but for some reason it did not. What I am looking for is a way to disable the option without having to move a main domain to a subfolder. Thanks for the help.
  • Chris BrownChris Brown USAMember Posts: 4,624 ✭✭

    _______ | http://forcoder.org | free video tutorials and ebooks about \ JavaScript, Python, MATLAB, Scratch, Objective-C, Ruby, Assembly, Perl, PHP, R, Delphi, Java, C++, C, Visual Basic .NET, PL/SQL, C#, Visual Basic, Swift, Go Lua, Fortran, Prolog, ABAP, Julia, Kotlin, Clojure, Logo, COBOL, Rust, LabVIEW, ML, FoxPro, Crystal, SAS, Alice, Hack, Transact-SQL, Lisp, Ada, Scala, F#, VBScript, Awk, Apex, Scheme, D, Dart, Bash, Erlang \ _______

Sign In or Register to comment.